9900KマシンをmacOS 10.14.5に更新する

(Cloverが対応したので古い情報です。)

第9世代CPU対応した公開版macOSである10.14.5が配布されました。更新したところCPUが「不明」の表記が改まりました。ただしCore i7になっているのでconfig.plistでCPU Typeを指定してCore i9と表示されるようにしました。

新iMac対応Mojaveが公開される

第8, 9世代CPUに対応したiMacが出た時点のmacOSは10.14.4でした。ただ対応したmacOSは製品に搭載されるだけで、他の機種IDのマシンでは入手できませんでした。先日(2019/5/14)ようやく10.14.5が公開され、最新CPUに正式対応したmacOSが入手できるようになりました。 早速、9900Kマシンをアップデートしました。問題なく動きます。

10.14.5から署名のないkextが除外されるという噂もありましたが、問題ありません。バニラなインストールをして、SIPも実機と同じく有効にしているから問題が無いのかもしれません。

CPUの名称表示を改善する

10.14.4ではCPUが「不明」

「このMacについて…」や「システム情報」を見るとCPU名が表示されます。しかし10.14.4では、以下のようにCPUが「不明」になっていました。

第9世代CPUを搭載したMacを対象にしていないバージョンでしたので、表示の用意がなかったと思われます。でもsysctlで確認すると、ちゃんと9900Kだと認識されています。

sysctl -n machdep.cpu.brand_string
Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz

10.14.5ではCPUが「Core i7」

10.14.5にアップデートしたところ、これがかなり改善されました。「このMacについて…」では以下のように表示されます。「不明」の表示は出なくなりました。でもなぜかCore i7の表示になります。

良いところまで来たのに、今一歩足りない感じです。そこでこちらで頂いたコメントを元に、こちらからCPU情報を確認して、CPU Typeに0x1009を設定しました。config.plistの最上位dictの中に、以下のようにkeyとdictを追加すれば良いようです。

追記:コメントいただいたように実機では0x1005だったという情報があります。0x1005の方が良いかと思い、以下も変更しました。

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>CPU</key>
	<dict>
		<key>Type</key>
		<string>0x01005</string>
	</dict>
</dict>
</plist>

この結果、Core i9と表示されるようになりました。(もしかしたら10.14.4でもCPU Type指定でこのようにできたのかもしれません)見た目だけなのかもしれませんが、CPU名が正しく表示されるようになると気分が良いです。

10.14.5 + Clover 4934ではCPUが「Core i9」

追記:Cloverをリビジョン4934に更新したらconfig.plistでCPU Typeに0x1009を設定なくても(上記の記述を全部削除しても)正しく3.9 GHz Intel Core i9と表示されるようになりました。ということで、Cloverが面倒を見てくれるようになったようですので、config.plistではCPU Typeを記載しないことにしました。ただ、「Clover 4934でiMac19,1にSMBIOS設定すると、i7 9700Kでもi9にされてしまう。」という報告が5chにありました。今後改善されると思います。

10件のコメント

  1. 自分もちょっと遅れて10.14.5にアップデートしました。基本的にスムーズにアップデートできましたが、RX570だと起動中プログレスバーの時画面上部に紫の線が出るようになりました。実害は無いようです。
    i7 9700Kを使ってるのでシステム情報は何もせず正確に表示されますね。

    9900Kについては、実物のiMacを調べた人がいてCPU Typeを0×1009にはするのでなく、0×1005とするという話もあります。

    https://www.tonymacx86.com/threads/smbios-19-x-imacs-2019.274686/page-38

    ここの#371のポスト以降に色々実物の9900Kの情報で色々模索がされています。WhateverGreen抜きでやる話なども。

    1. ありがとうございます。私も0x1005にしました。本文に反映しておきました。

    2. 情報ありがとうございます、僕も0x1005にして無事に反映しました。

  2. 一般的なデスクトップとしては9900Kマシンは羨望の的であり、それがをMACOS 10.14.5にて無事稼働・正しく認識されるのは誠に喜ばしいことと感じます。
    ところで初歩的な質問で恐縮ですが「9900Kマシン・MACOS 10.14.5」において、ハイパースレッド機能はENABLEで実働していますか?なにか特殊な設定が必要でしょうか?

    質問の背景: 我がHacintosh(Z170Mチップ搭載のマザボ、Intel 6700K, Mojave 10.14.6 Public Beta 1) において、ハイパースレッドをENABLEにするとブート手順の途中でフリーズしてしまいます。
    お手数ですが、ご教示いただけると幸いです。

  3. [Success] あきらめずに頑張った奮闘し数十分、ようやく我が Hacintosh(Z170M, 6700K)にてActivity Monitor.appで「CPUの使用率」を開くと、8本の棒グラフが出てきました。プチですがまさに圧巻。

    1) 朝 返信内容を拝見し、”失敗を恐れずにチャレンジする勇気”をもらいました。
    アドバイスいただいた方法 :「多分DSDTのCPU関係の情報が正しくないのかもしれないので、ssdtPRGen.shでSSDTを作ってみてはどうでしょう。」をトライ。
    2) 久しぶりのLinuxコマンド、スクリプトの実行方法を再学習しながら実施。

    的確なアドバイスとこれまでの意義ある情報・経験の公開に、深く感謝いたします。

    1. 後記: 上記コメントを投稿してから、約3週間経過した今日。 ようやくConfig.plist、ACPIフォルダーとkextフォルダーのそれらの内容を最適化して、HT-Enabledを安定稼働することが出来た。
      忘備録を兼ねてここに記しておきたい。

      Clover r4988
      Imac18,3
      boot (dart=0, nv_disable=1, -no_compact_check, -lilubetaall )
      ACPI/patched/ssdt.amlを追加
      通常の主要なkextに加えて、NullCPUPowerManagement.kextを追加

  4. 参考情報:「10.14.5にアップデートしました。基本的にスムーズにアップデートできましたが、RX570だと起動中プログレスバーの時画面上部に紫の線が出る」件に関する対応策 ーー

     確かに、我がHacintosh(Z170M,6700K、RX570-8GB)においても10.14.5にアップデート(Public Beta 1~6, および正式版)において、上述の紫の線が出ていました。 
    しかしながら、Kext Updaterアプリからの推奨内容に沿って、以下の2つのKextを最新版に変えて(さらに10.14.6 Public Beta 1にアップグレードしたら)、この紫の線が出なくなりました。
     Liu.kext V1.3.5
    WhateverGreen.kext V1.2.8
     

    1. 手元のRX580では、まだ紫の線が出ます。Liluは1.3.6でWhateverGreenは1.2.9でmacOSは10.14.5です。10.14.6で直るのかも

  5. こんにちは。
    脱Sandyおじさんさんが報告されてるように、
    10.14.5のグラフィックドライバの兼ね合いで、私も紫/ピンクな横線がOS起動時に出ます。
    現状「仕様=しようがない」って分かってても、何か気持ち悪いですよね(´;Д;`)

bootmacos にコメントする コメントをキャンセル

メールアドレスが公開されることはありません。

「名前」「メールアドレス」「サイト」は空白でも投稿できますが、日本語が含まれない投稿は無視されます。(スパム対策)