【助けて】MontereyにしたらGPUのDisplayPortが効かなくなった

ホーム フォーラム Discussions 【助けて】MontereyにしたらGPUのDisplayPortが効かなくなった

  • このトピックには17件の返信、1人の参加者があり、最後にカナやんにより1週、 6日前に更新されました。
13件の返信スレッドを表示中
  • 投稿者
    投稿
    • #13842 返信
      キクエセロ
      ゲスト

      はじめまして。いつも拝見しております。

      早速本題なのですが、昨日Montereyをクリーンインストールしたところ、GPUのDisplayPortから映像出力が出来なくなりました。
      Opencoreならびに別のSSDに入れているWindowsでは認識していますよ。
      MacOSを起動すると信号が送られなくなる状態です。
      マルチディスプレイにしていて、1枚目はDisplayPortport、2枚目はHDMIになってます。
      どうすればDisplayPortportが信号を送るようになるでしょうか?知恵をお貸しください。

      Hackintosh

      マザーボード
      ASUS STRIX Z390-F GAMING
      CPU
      Intel CPU Corei9-9900K
      CPUクーラー
      サイズ 忍者五
      ケース
      NZXT H510
      グラフィックボード
      GIGABYTE AMD Radeon RX6800
      メモリ
      TEAM DDR4 2666Mhz PC4-21300 16GBx2
      電源
      玄人志向 80 PLUS GOLD認証 750W KRPW-GK750W/90+
      M.2 SSD
      Western Digital WD Black 250GB NVMe WDS250G3X0C(Hackintoshデータ用)
      SSD
      Samsung SSD 1TB 860QVO(Hackintosh用)
      Samsung SSD 1TB 860QVO(Windows用)

      OPENCORE 0.7.5

      お力添えよろしくお願いします。

    • #13843 返信
      通りすがりの者
      ゲスト

      グラフィックボードは、GIGABYTE AMD Radeon RX6800を使っていらしゃるとは、すごいですね。

      Hacintosh環境で突然の不具合発生は、いつものことなので驚きませんが、今回の障害の原因を探る上で、以下の点がとても気になります。問題領域の判別のために、ご教示願います。

      Q1:Samsung SSD 1TB 860QVO(Windows用)..と 明示されていることから判断して、このマザボでWindowsを可動なさっていますか?
       もしWindowsが稼働している時は、このDisplayPort 経由で正しく表示できていますか?

      Q2:”昨日Montereyをクリーンインストールしたところ、GPUのDisplayPortから映像出力が出来なくなりました。”…とありますが、
      Montereyではなく Big Sur(最新版 11.6.1 )で動かした場合は、どうなりますか?
      同じように、GPUのDisplayPortから映像出力が出来なくなりますか?

      Q3: Montereyをクリーンインストールする前に、OpenCore環境において 主要なKextは最新版に更新されていますか?

    • #13844 返信
      キクエセロ
      ゲスト

      返答ありがとうございます。

      Q1 こちらに関しては最初のスレッドにも書いてある通りWindowsおよびOPENCOREでは認識しております。

      Q2 bigsurの時は動いておりました。が、OPENCOREのアップデートを怠っており、動いていた時は0.6.6でした。クリーンインストールをするに当たり、config をゼロから書き換えました。

      Q3 クリーンインストールする際に最新にしました。

    • #13845 返信
      bootmacos
      キーマスター

      「OpenCore 0.6.6 + Big Sur」の時はDPが動いていて、
      「OpenCore 0.7.5 + 新config.plist + Monterey」にした動かなくなった、ということですね。
      「OpenCore 0.7.5 + 新config.plist + Big Sur」はためされてますか?

    • #13846 返信
      キクエセロ
      ゲスト

      試してみました。けどDPが動作しなかったので新config.plistが悪いのかもしれませんが、どこが悪いのかよくわかりません。

      あと検証してみたらLou.kext を最新版にすると起動がしなくなりました。

      それともう一つ不具合があって、kext updater がkextを認識して、最新版を示してはくれるのですがダウンロードされません。

      困り果ててます。

      EFIファイルを添付するので確認よろしくお願いします。

      https://xgf.nu/ucRh

    • #13847 返信
      キクエセロ
      ゲスト

      ごめんなさい。Lilu.kextです。
      それを最新版にするとで完全にブラックアウトします。

    • #13848 返信
      bb
      ゲスト

      0.7.2からUEFI/Driversの記述が変更になっていますがそれは対応されていますか?

      OpenCore 0.7.2から0.7.3に更新

    • #13851 返信
      キクエセロ
      ゲスト

      この書き方に関しては、もともとconfig.plist を触るときにOPENCORE CONFIGURATERを使用していて、新config.plist を作成の際、0.7.5に付いているsample.plistを使用しました。

      無知で無知で分けないですがOPENCORE CONFIGURATERでは対応できてないのでしょうか?

    • #13852 返信
      bootmacos
      キーマスター

      boot-argsに
      -v keepsyms=1 alcid = 1 agdpmod = pikera
      とありますが
      -v keepsyms=1 alcid=1 agdpmod=pikera
      と書いたほうが良いと思います。スペースがあると別のパラメータだと判定されてしまいます。

      • この返信は2週、 3日前にbootmacosが編集しました。
    • #13853 返信
      キクエセロ
      ゲスト

      -v keepsyms=1 alcid=1 agdpmod=pikera
      に直してみましたが、ダメでした。。

    • #13855 返信
      bootmacos
      キーマスター

      Lilu.kextは最新にしてありますか?
      agdpmod=pikeraが効けば、ブラックスクリーンにはならないで済むのではと思います。
      Liluが無いとWhatevergreenも動かず、その結果、DPから映像が出ないのではないかな。

      • この返信は2週、 2日前にbootmacosが編集しました。
    • #13858 返信
      キクエセロ
      ゲスト

      ありがとうございます!

      Lilu.kextを最新にしたことにより無事DPから信号を読み取りました。
      本当に助かりました。ありがとうございます😭

    • #13859 返信
      キクエセロ
      ゲスト

      大変申し訳ありません。もう一つ質問で
      kext updater がkextを認識して、最新版を示してはくれるのですがダウンロードされません。という問題に関して何か解決策はありませんか?

      • #13867 返信
        bootmacos
        キーマスター

        最新版のチェックはしてくれるのでしたら、ちょっと手間はかかるけど、Kextmanagerのボタンから手作業でダウンロードしても良いかもですね

        • #13868 返信
          キクエセロ
          ゲスト

          それもやってみたんですが、ダウンロード自体されなくて。あれれーおおかしいぞぉって感じです

    • #13862 返信
      bootmacos
      キーマスター

      Kext Updaterの問題点に心当たりがないのですが、何かエラーメッセージのようなものは出ていませんでしょうか?

      • #13866 返信
        キクエセロ
        ゲスト

        なにも出てなくて、とりあえず最新版との照合はしてくれるんですが、ダウンロードがされないです。。。

13件の返信スレッドを表示中
返信先: 【助けて】MontereyにしたらGPUのDisplayPortが効かなくなった
あなたの情報: