【HELP】GIGABYTE Z390 AORUS ELITE

ホーム フォーラム User Builds 【HELP】GIGABYTE Z390 AORUS ELITE

  • このトピックには14件の返信、2人の参加者があり、最後にbootmacosにより4週、 1日前に更新されました。
14件の返信スレッドを表示中
  • 投稿者
    投稿
    • #7033 返信
      くれあ
      ゲスト

      こちらのサイトや海外のサイトなどを参考に以下の構成でHackintoshに挑戦しました。

      □構成
       MBD GIGABYTE Z390 AORUS ELITE
       CPU i7 8700
       MEM 32GB
       VIDEO RADEON RX580
       Strage m.2 500GB

      □Soft
       Clover 5098
       macOS 15.15.1(macbook proよりダウンロード)

      □手順
       mac bookproでダウンロード
       外付けSSDにインストール
       cloverをインストール
       configp.list(海外の方の物を流用。ただしserial、SmUUID、Boaurd Serialはcllover Configで精製)
       以下のkextとDriverをコピー
        AppleALC
        FakeSMC
        IntelMausiEthernet
        LiLu
        USBInjectAll
        USBPorts
        WhateverGreen

        AppleDriverLoarder
        AudioDxe
        DataHubDxe
        EmuVariableUefi
        FSInject
        OsxAptioFix2Drv-free2000
        SMCHelper
        VBoxHfs

      □結果
       通常の起動や、iMessage、MUSIC、など問題なく動作しております。

      □課題
       スリープができない→スリープをクリックすると画面は消えるが本体は動作している様子
                 キーボードやマウスのクリックでログイン画面になり、ログインすれば
                 問題なく動作
       音がでない→ALC1220を認識していないのか、設定→サウンドをみてもHDMIしかでない。
             HDMIで問題なく視聴できるが、音量調整ができないので不便

      ここまでたどり着くまでに、ASUSのMBD2枚購入(そのうちの1枚はrog maximus xi hero)して
      みたり。なにもわからずようやくここまでたどり着けました。
      なんとか上記二つの課題をクリアしたいです。
      みなさまのアドバイスをお待ちしております。

    • #7035 返信
      bootmacos
      キーマスター

      スリープは厄介な項目ですね。config.plistを(シリアルなどは伏せ字にして)公開していただけるといろいろ意見をもらえるかも。スリープしてもすぐに目覚めるという症状ではなくて、そもそもスリープしないような感じなのでしょうか?時間をかけて待ってもだめでしょうか。HDD/SSDへのアクセスが続いているようなら準備中なのかもしれないです。ターミナルでpmset -gするとその結果はどのようなものでしょうか。

      オーディオはAudio – Inject – 1で大体大丈夫な気がします。1の他に、2, 3, 5, 7, 11, 13, 15, 16, 21, 27, 28, 29, 34などの可能性もあるようですが試されましたか?

      https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

      ROG MAXIMUS XI HEROはまだお持ちですか?手元ではこれと9900Kでスリープもオーディオも動いています。OsxAptioFix2Drv-free2000も使わずにOsxAptioFix3Drv.efiで動きます。8700も同じような設定で動く気がします。もしマザボを取り替えても良いようでしたら、以下の関連記事を参考になさってください。

      ASUS ROG MAXIMUS XI HERO (Z390), 9900K

      • この返信は1ヶ月前にbootmacosが編集しました。
    • #7038 返信
      くれあ
      ゲスト

      bootmacos様
      早速のご返信ありがとうございます。
      実は、まだROG MAXIMUS XI HEROをもっております。
      このMBDのときはそもそも母艦からSSDを付け替えたら、起動しませんでした。(進入禁止マーク)
      あとファンコントロールがASUS製は私には向いていないように感じ、GIGABYTEに戻しました。
      もともとすごく丁寧に手順が載っていたので、大丈夫かと思ったのですがだめでした。
      で、話を現在に戻すと、injectは6つほど試しましたが、今のところ変わらずです。
      また、スリープは一度本体も落ちるのですが直ぐに復帰する状態です。
      pmset -gの結果は以下のとおりです。

      System-wide power settings:
      Currently in use:
      standby 1
      Sleep On Power Button 1
      womp 0
      hibernatefile /var/vm/sleepimage
      proximitywake 1
      powernap 0
      gpuswitch 2
      networkoversleep 0
      disksleep 10
      standbydelayhigh 86400
      sleep 15 (sleep prevented by mds_stores, UserEventAgent, sharingd)
      hibernatemode 3
      ttyskeepawake 1
      displaysleep 15
      highstandbythreshold 50
      standbydelaylow 86400

      config.plistは以下のとおりです。(先述したとおり、外国の方の物を利用しております。)

      <!DOCTYPE plist PUBLIC “-//Apple//DTD PLIST 1.0//EN” “http://www.apple.com/DTDs/PropertyList-1.0.dtd”&gt;
      <plist version=”1.0″>
      <dict>
      <key>ACPI</key>
      <dict>
      <key>AutoMerge</key>
      <true/>
      <key>DSDT</key>
      <dict>
      <key>Fixes</key>
      <dict>
      <key>FixHPET</key>
      <false/>
      <key>FixIPIC</key>
      <false/>
      <key>FixMutex</key>
      <false/>
      <key>FixRTC</key>
      <false/>
      <key>FixRegions</key>
      <false/>
      <key>FixShutdown</key>
      <false/>
      <key>FixTMR</key>
      <false/>
      </dict>
      <key>Patches</key>
      <array>
      <dict>
      <key>Comment</key>
      <string>change SAT0 to SATA</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>
      U0FUMA==
      </data>
      <key>Replace</key>
      <data>
      U0FUQQ==
      </data>
      </dict>
      <dict>
      <key>Comment</key>
      <string>change HECI to IMEI</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>
      SEVDSQ==
      </data>
      <key>Replace</key>
      <data>
      SU1FSQ==
      </data>
      </dict>
      </array>
      </dict>
      <key>DropTables</key>
      <array>
      <dict>
      <key>Signature</key>
      <string>DMAR</string>
      </dict>
      <dict>
      <key>Signature</key>
      <string>MATS</string>
      </dict>
      </array>
      <key>FixHeaders</key>
      <true/>
      <key>HaltEnabler</key>
      <false/>
      <key>SSDT</key>
      <dict>
      <key>Generate</key>
      <dict>
      <key>PluginType</key>
      <true/>
      </dict>
      <key>NoDynamicExtract</key>
      <true/>
      <key>NoOemTableId</key>
      <true/>
      </dict>
      </dict>
      <key>Boot</key>
      <dict>
      <key>Arguments</key>
      <string>keepsyms=1 dart=0 debug=0x100 slide=0 darkwake=8 shikigva=32 -alcoff</string>
      <key>DefaultVolume</key>
      <string>LastBootedVolume</string>
      <key>Timeout</key>
      <integer>5</integer>
      <key>XMPDetection</key>
      <string>Yes</string>
      </dict>
      <key>Devices</key>
      <dict>
      <key>Audio</key>
      <dict>
      <key>Inject</key>
      <integer>1</integer>
      <key>ResetHDA</key>
      <true/>
      </dict>
      <key>USB</key>
      <dict>
      <key>AddClockID</key>
      <false/>
      <key>FixOwnership</key>
      <true/>
      <key>HighCurrent</key>
      <true/>
      <key>Inject</key>
      <true/>
      </dict>
      </dict>
      <key>GUI</key>
      <dict>
      <key>Hide</key>
      <array>
      <string>Recovery</string>
      <string>Preboot</string>
      </array>
      <key>Scan</key>
      <dict>
      <key>Entries</key>
      <true/>
      <key>Legacy</key>
      <true/>
      <key>Linux</key>
      <false/>
      </dict>
      <key>ScreenResolution</key>
      <string></string>
      <key>Theme</key>
      <string>embedded</string>
      </dict>
      <key>Graphics</key>
      <dict>
      <key>Inject</key>
      <dict>
      <key>ATI</key>
      <false/>
      <key>Intel</key>
      <false/>
      <key>NVidia</key>
      <false/>
      </dict>
      </dict>
      <key>KernelAndKextPatches</key>
      <dict>
      <key>AppleIntelCPUPM</key>
      <false/>
      <key>KernelPm</key>
      <true/>
      <key>KextsToPatch</key>
      <array>
      <dict>
      <key>Comment</key>
      <string>External Icons Patch</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>
      RXh0ZXJuYWw=
      </data>
      <key>InfoPlistPatch</key>
      <false/>
      <key>Name</key>
      <string>AppleAHCIPort</string>
      <key>Replace</key>
      <data>
      SW50ZXJuYWw=
      </data>
      </dict>
      </array>
      </dict>
      <key>RtVariables</key>
      <dict>
      <key>BooterConfig</key>
      <string>0x28</string>
      <key>CsrActiveConfig</key>
      <string>0x67</string>
      <key>MLB</key>
      <string>{{PASTE BOARD SERIAL NUMBER HERE}}</string>
      <key>ROM</key>
      <string>UseMacAddr0</string>
      </dict>
      <key>SMBIOS</key>
      <dict>
      <key>BiosReleaseDate</key>
      <string>05/28/2019</string>
      <key>BiosVendor</key>
      <string>Apple Inc.</string>
      <key>BiosVersion</key>
      <string>IM191.88Z.F000.B00.1905281819</string>
      <key>Board-ID</key>
      <string>Mac-AA95B1DDAB278B95</string>
      <key>BoardManufacturer</key>
      <string>Apple Inc.</string>
      <key>BoardSerialNumber</key>
      <string>{{GENERATE ME}}</string>
      <key>BoardType</key>
      <integer>10</integer>
      <key>BoardVersion</key>
      <string>1.0</string>
      <key>ChassisAssetTag</key>
      <string>iMac-Aluminum</string>
      <key>ChassisManufacturer</key>
      <string>Apple Inc.</string>
      <key>ChassisType</key>
      <string>0x09</string>
      <key>EfiVersion</key>
      <string>220.270.76.0.0</string>
      <key>Family</key>
      <string>iMac</string>
      <key>FirmwareFeatures</key>
      <string>0xFD8FF576</string>
      <key>FirmwareFeaturesMask</key>
      <string>0xFF1FFF3F</string>
      <key>LocationInChassis</key>
      <string>Part Component</string>
      <key>Manufacturer</key>
      <string>Apple Inc.</string>
      <key>Mobile</key>
      <false/>
      <key>PlatformFeature</key>
      <string>0x00</string>
      <key>ProductName</key>
      <string>iMac19,1</string>
      <key>SerialNumber</key>
      <string>************</string>
      <key>SmUUID</key>
      <string>********-****-****-****-************</string>
      <key>Version</key>
      <string>1.0</string>
      </dict>
      <key>SystemParameters</key>
      <dict>
      <key>InjectKexts</key>
      <string>Yes</string>
      <key>InjectSystemID</key>
      <true/>
      </dict>
      </dict>
      </plist>

    • #7039 返信
      bootmacos
      キーマスター

      スリープはするけどすぐに目覚めるというのは、スリープさせる設定としては正しいと思います。mpget -gの方ですがsleep prevented by mds_stores, UserEventAgent, sharingdとあるので、そのどれかでスリープから起こされていると思います。以下の方法で原因を探れるかと思います。

      mds_storesはSpotlightの索引製作などと関係ありそうです。システムをインストールした直後は、しばらくはspotlightが準備するので、仕方ないかもしれません。数日待ってみるか、システム環境設定のSpotlightのプライバシーで、どのドライブも索引を作らない設定にすると良いかもです。

      UserEventAgentはUSB機器などのイベントです。HDMIからのイベントもあり得ます。USBを全て引っこ抜いて(BTとキーボード、トラックパッドくらいは残しても良いかも)、HDMIも外して調べてみるのも良いかもです。USBハブが原因だったことがあります。外したらスリープするようになりました。

      Sharingdはネット経由で共有要求がきて起こされたというようなものだと思います。有線LANもWiFiも切って、調べてみるんも良いと思います。もしこれが原因なら、BIOSでLANで目覚める設定を外すとか、省エネルギー設定でネットワークアクセスによるスリープ解除を無効にする、Power Napを無効にするなどで対応できるかと思います。

    • #7040 返信
      bootmacos
      キーマスター

      config.plistの方ですが、{{PASTE BOARD SERIAL NUMBER HERE}}と、{{GENERATE ME}}のところは実際にはボードシリアル番号が入っていますでしょうか。

    • #7044 返信
      くれあ
      ゲスト

      アドバイスありがとうございます。
      結局昨夜遅くまでねばったのですが、状況に変化はなくMBDをASUSにもどしました。(ROG Maximus)
      で、今回はいただいたリンクのほうでインストールし、plistもリンクからダウンロードしファイル名を
      直して(拡張子含む)clover configratorでシリアルなどを修正しました。
      その状態でssdを取り付け起動すると、前回は禁止マークが出ておりましたが、今回は文字列の途中までいき
      止まってしまいます。
      ちなみに、旧記事と新記事にリンクされているplistでは内容が違うのでしょうか?
      文字列で止まる内容が変わります。
      kext関連は新記事の方に合わせました。ちなみに先日のアドバイスの中に記載されていたOsxAptioFix3Drv.efi
      は記事の中にはなかったので、入れておりません。入れたほうが良かったでしょうか?

    • #7048 返信
      bootmacos
      キーマスター

      どの記事のconfig.plistも、同じpastebin.comリンクになっていたと思うのですが、違うものを紹介しているようでしたらご指摘ください。修正しておきます。あと、記事を書いた当時とはCloverのバージョンが変わり、efiドライバのディレクトリ構造が変わっていますので、ご注意ください。OsxAptioFix3Drv.efiの方が良いようですので、OsxAptioFix2Drv-free2000.efiと差し替えておいた方が良いと思います。ただ、起動する・しないには影響ないです。どちらも起動します。

    • #7049 返信
      bootmacos
      キーマスター

      もしかしたらRTCの問題なのかも。

      ASUSのBIOSを1105に更新すると起動しない

    • #7050 返信
      くれあ
      ゲスト

      ごれんらくありがとうございます。
      RTCは私もBIOSを最新にしてしまっていたので、記事を参考に1005に戻しました。
      で、本日は思考をかえて、USBにOSを入れCloverのインストール、Kextのインストール、smbiosの変更と
      インストールUSBを作成して行っていますが、やはり途中で止まってしまいます。
      waiting on <dict ID=”8″><key>IOProviderClass・・・・・
      のところです。

      念のための確認ですが、今利用しているcloverは最新です。この前提で
       記載のconfig.plistはそのまま利用可能ですか?
       もちろんkextとドライバーは所定のフォルダに入れております。
      もし、バージョンにより記載内容に変更が必要であればご教授ください。

      休みも明日までなので、がんばります!

    • #7051 返信
      bootmacos
      キーマスター

      例として公開しているconfig.plistは、現在使用しているconfig.plistとほぼ同じなので、問題なく動くと思います。お使いのESPをどこかに置いていただけるようなら、試してみましょうか?

    • #7058 返信
      くれあ
      ゲスト

      ご提案ありがとうございます。
      お言葉に甘えて、以下のgoogleドライブにEFIをzip形式に圧縮しアップしておりますので
      ご確認ください。

      https://drive.google.com/file/d/1s3JGum6-oKvdwgX2KglNnvAgUanwkdRy/view?usp=sharing

    • #7059 返信
      bootmacos
      キーマスター

      EFIありがとうでした。早速手元のASUS ROG MAXIMUS XI HEROと9900K+RX 580, macOS 10.15.1で試してみました。次のことがわかりました。

      (1)
      まずは私のところで動いているconfig.plistを入れて動かしてみました。GPUに切り替わるところまで行きますが、画面が暗いままでした。どうやらWhateverGreen.kextが古いようで1.3.1でした(最新は1.3.4)。
      他も調べてみると、Cloverやkextやefiなどが古いようです。BOOTX64.efi, CLOVERX64.efiなどが9月6日のタイムスタンプです。タイムスタンプは圧縮などの時に変わったかもしれないのであてにならない気もしますが、もし本当ならCatalinaが出る前のバージョンです。kextも、一部新しいのもありますが、古いものもあります。例えばLilu.kextが1.3.8(最新は1.3.9)で、AppleALC.kextが1.4.0 (最新は1.4.3)でした。
      これらを最新にしたら私のところのconfig.plistで起動しました。多分WhateverGreenが最新になったのが効いていると思います。

      (2)
      Clover, kext, efiを最新にしたところで、いただいたconfig.plistのSMBIOSを私のマシンの内容に書き換えて起動試みました。起動しませんでした。私のところのconfig.plistと比較したところ以下のことがわかりました。pastebinでconfig.plistを公開した後、以下の記事で紹介したように、パッチの内容を整理していました。ここで追加したEC0 —> ECのパッチが今のmacOSでは必須になっていたようです。これが無いとapfsの読み込み途中で止まっていました。追加したところ起動するようになりました。ちなみにXHCIなどのパッチは不要でした。この内容に基づいて、pastebinで公開しているconfig.plistも修正しました。

      config.plistでDSDT項目名を変更するパッチ

      ということで、Clover, kext, efiを最新にして、EC0 —> ECのパッチを追加すれば動くと思います。お試しください。EC0のパッチが必須なことがこれを機会にわかりました。ありがとうございました。

      • この返信は4週、 1日前にbootmacosが編集しました。
      • この返信は4週、 1日前にbootmacosが編集しました。
      • この返信は4週、 1日前にbootmacosが編集しました。
      • この返信は4週、 1日前にbootmacosが編集しました。
      • この返信は4週、 1日前にbootmacosが編集しました。
      • この返信は4週、 1日前にbootmacosが編集しました。
      • この返信は4週、 1日前にbootmacosが編集しました。
      • この返信は4週、 1日前にbootmacosが編集しました。
    • #7066 返信
      くれあ
      ゲスト

      bootmacos様
      先ほどアドバイスいただいた方法で無事インストールが完了し、ほぼ問題なく動作しております。
      まだ全てを確認できたわけではないですが、以下の主要機能は動作しております。
       iCloud
       Music
       Facetime
       imessage
       シャットダウン

      一時はまったく迷走に状態になり、色々な方のEFIやドライバ、Kextなどを試しているうちに
      バージョンなども混ざってしまったようです。(ご指摘通り。WhateverGreenとパッチでした)
      この度は本当にありがとうございました。

    • #7067 返信
      くれあ
      ゲスト

      記載もれがございました。
       サウンド、USB、Bluetooth、Wi-Fiなどハードウェアも完璧です!

    • #7070 返信
      bootmacos
      キーマスター

      おめでとうございます。動いてよかったです。

14件の返信スレッドを表示中
返信先: 【HELP】GIGABYTE Z390 AORUS ELITE
あなたの情報: