[そこそこSUCCESS]ASrock Phantom GAMING 6,ASRock RADEON VII, GIGABYTE GC-TITAN RIDGE

ホーム フォーラム User Builds [そこそこSUCCESS]ASrock Phantom GAMING 6,ASRock RADEON VII, GIGABYTE GC-TITAN RIDGE

  • このトピックには16件の返信、1人の参加者があり、最後にbootmacosにより3日、 2時間前に更新されました。
15件の返信スレッドを表示中
  • 投稿者
    投稿
    • #6535 返信
      匿名
      ゲスト

      デジカメのRAW現像、音楽制作を目的としたマシンです。

      ハードウェア構成
      ・マザーボード ASRock Phantom gaming 6
      ・CPU Intel Core i9-9900K
      ・CPUクーラー DEEPCOOL GAMMAXX L240 DP-H24RF-GL240RGB
      ・GPU ASRock Radeon VII
      ・メモリ Team DDR4 3200Mhz(PC4-25600) 16GBx2枚
      PATRIOT Viper4 シリーズ DDR4 3200MHz 16GBx2枚
      ・ストレージ WD BLACK SN750 NVMe 500GB x 2
      ・Timemachine用 SSD SanDisk SSD Ultra 3D 500GB SATA3.0
      ・電源 Antec 80PLUS GOLD認証取得 高効率高耐久電源ユニット NE750 GOLD
      ・Thunderbolt GIGABYTE GC-TITAN RIDGE Thunderbolt3
      ・Wifi/BT Oley 変換アダプター WiFi + Bluetooth 4.0 カード → PCI-E 変換アダプターPC/Hackintosh 対応、BCM943602CS
      ・PCケース Thermaltake Versa H26
      ・同期型RGBケースファンを3台(ノーブランド)

      動くこと
      ・iMessage,iCloud,iTunes,Bluetooth,Wifi,sleep,shut down,Applewatch Sries4によるロック解除,Airplay,私のEFIではUSB 15個制限は解除して使えます。

      動かないこと
      ・RADEON VIIからDP出力で一枚、Thunderbolt 3 経由でディスプレイ1枚を出力しますが
       音が出ません。外付けスピーカーでマザボから音を出しています。
      ・Thunderbolt3のHot Plugは無理なので必要なら再起動をしています。
      ・現在のCatalina BETAではSIDECAR使用時iPAD PRO側はブラックスクリーン。

      ・ポイント
       1.ASRock Phantom gaming 6 と9900Kの構成はヤフオクで制作したものを入手しました。
        ただし、このマザボでの成功例はtonymac86.comでたった一つのみ
        様々な不具合と闘い、ようやく落ち着いたところです。
      2.Turbo Boost時、5.1GHz全コアで動かせます。
       3.メモリは3200MHzから3466MHzにOCしています。
       4.OSはCatalina BETA 19A558d
       5.この構成でやりたかったことはデジカメのRAW現像です。動画編集はしていないので
        ひとまずiGPUはdisabledとし、特段不具合はありません。
       6.DSDTはClover boot画面上で取得したものを使用中
       7.SSDTはtonymacx86.comのフォーラムよりThunderbolt3関連のものだけ拝借
       8.Thunderblt関連は最初からUSBハブ、Thunderboltケーブルのみを繋げた状態にし、
        後からカメラ、ポータブルHDD等を接続すると認識されます。
      9.SMBIOSはiMac pro1,1、Radeon VIIの能力がiMac 19,1よりも高いと海外フォーラムのあちこちで見かけたため

       以上、興味ある人や実際同じマザボで挑戦する人がいれば質問ください。
       基本的には成功事例が少ないため、おすすめできる構成ではありません。

    • #6537 返信
      bootmacos
      キーマスター

      報告ありがとうございます。Radeon VIIは動いているんですね。

      >>6.DSDTはClover boot画面上で取得したものを使用中

      Cloverのブート画面で取得するDSDTは、マザーボードオリジナルのDSDTと、Cloverがパッチを当てた後のDSDTだと思います。前者の方は、パッチが当たっていないので、使ったら動作しないと思われますし、後者の方は、CloverがそのようにDSDTをすでに読み換えてくれているので、取得して使用する必要はないと思っていたのですが、どうなのでしょう?

      • #6542 返信
        匿名
        ゲスト

        bootmacos様

        ご指摘の通り、DSDT.amlを入れた状態、外した状態でGeekbench 4のスコアが同じであったため、
        DSDTを外しました。USBの設定のため、SSDTのみを残しました。

    • #7546 返信
      narihiro
      ゲスト

      こんにちは
      narihiroと申します。

      投稿を拝見させていただきました。
      bootmacos様には「PCIE拡張カードでSATAを増設する」でお世話になりました。
      ありがとうございました。

      私も、ASRock Z390 Phantom Gaming 6とこの度Radeon Ⅶを装着し構成しております。
      Cataline(10.15.2)でほぼ正常に動作しておりますが、1点だけつまづいております。

      スリープ復帰後に50%程度の確率で、画面が復帰せずに黒画面のままの状態になってしまいます。
      上手くいく時もあります。dr.debugは大抵”7F”が表示されております。
      同じ構成でRX590を装着していた時には100%正常にスリープ復帰しておりました。
      ブログ内の「9900KのSLEEP問題〜原因はIGPUのデバイスID」の内容も試してみたのですが、
      うまくいきませんでした。

      お知恵をお貸しいただければ幸いです。
      もしよろしければ、”config,plist”の内容も教えていただきたく、お願い申し上げます。

      構成
      CPU:Intel Core i7-8700K
      マザーボード:ASRock Z390 Phantom Gaming 6
      電源:Thermaltake Toughpower Grand RGB 850W
      グラフィックボード:XFX AMD Radeon VII
      メモリ:32GB
      SSD(Mac用):M.2 NVMe 256GB(OS用)、2.5インチSATA 480GB(データ用)
      SSD(Windows用):M.2 NVMe 256GB(OS用)、2.5インチSATA 480GB(データ用)
      OS:MacOS10.15.2 Catalina
      Clover:Ver.r5099
      Kexts:AHCI_3rdParty_SATA、AppleALC、FakeSMC_ACPISensors、FakeSMC_CPUSensors、
          FakeSMC_GPUSensors、FakeSMC_LPCSensors、FakeSMC_SMMSensors、FakeSMC、
          IntelMausiEthernet、Lilu、NoVPAJpeg、USBInjectAll、WhateverGreen。
      Driver:ApfsDriverLoader、AudioDxe、DataHubDxe、EmuVariableUefi、FSInject、
          OsxAptioFix2Drv-free2000、SMCHelper、VBoxHfs

    • #7554 返信
      匿名
      ゲスト

      narihiro様

      私の環境ではスリープは下記の設定でできるものの、スリープ復帰後に
      挙動が不安定でフリーズしてしまうことがあり、現在も調査中です。

      STOP MACOS FROM FREEZING DURING SLEEP/WAKE ON A CATALINA HACKINTOSH

      上記のリンクにAppleALC.kextに由来するスリープの設定方法の解説があります。
      <?xml version=”1.0″ encoding=”UTF-8″?>
      <!DOCTYPE plist PUBLIC “-//Apple//DTD PLIST 1.0//EN” “http://www.apple.com/DTDs/PropertyList-1.0.dtd”&gt;
      <plist version=”1.0″>
      <dict>
      <key>AAPL,slot-name</key>
      <string>Internal@0,31,3</string>
      <key>device-id</key>
      <data>cKEAAA==</data>
      <key>device_type</key>
      <string>Audio device</string>
      <key>hda-gfx</key>
      <data>qqqqqqo=</data>
      <key>layout-id</key>
      <integer>1</integer>
      <key>model</key>
      <string>Cannon Lake PCH cAVS</string>
      </dict>
      </plist>
      config.plistのDevice/Propertiesの中に上記のような設定を加えています。

      Catalinaになってから特にスリープが不安定になったと感じます。

      是非参考になさってください。

    • #7555 返信
      narihiro
      ゲスト

      匿名様

      早速のご返信、ありがとうございます。

      私も以前海外のサイトで書かれていた、AppleALC.kextがスリープに関係していることを思い出し
      試しに削除して現在検証中です。今のところスリープ解除後の問題は起こっていないようです。
      音もDP出力でモニターのスピーカーもしくはUSB出力のスピーカーからノイズ等無く出力されております。
      AppleALC.kextの代わりにVoodooHDA.kextを使用してみましたが、同じくスリープ解除に失敗しました。
      教えていただいた方法も試してみます。ありがとうございます。
      もう少し検証して、またご報告させていただきます。

      もう一つ別件でお尋ねしたいのですが、
      config.plistのGraphics項目で”Inject ATI”を選択しないと
      起動途中でフリーズしてしまうのですが、匿名様も同じでしょうか?

    • #7556 返信
      narihiro
      ゲスト

      追伸です。

      上記のリンク先の方法は試しておりました。
      残念ですが、状況は変わらずでした。

    • #7560 返信
      匿名
      ゲスト

      narihiro様

      config.plistのGraphics項目は
      <key>Graphics</key>
      <dict>
      <key>Inject</key>
      <dict>
      <key>ATI</key>
      <false/>
      <key>Intel</key>
      <false/>
      <key>NVidia</key>
      <false/>
      </dict>
      </dict>
      となっていて、Inject ATIはFalseです。
      起動途中でフリーズの経験はありません、
      Boot Argumentsにて-vを加え、フリーズの原因を探ることはできないでしょうか?
      この辺の設定で問題を起こしたことがないので
      あまり参考にならないかと思います。

      よろしくお願い申し上げます。

    • #7563 返信
      narihiro
      ゲスト

      匿名様

      Graphics項目の件ありがとうございます。

      私の環境では、”ATI Inject”にをtrueにしないと、まともに動作しないようです。
      上記の構成で書き忘れておりましたが。
      PCI-EにWiFiとSATA増設カードとM.2のSSD RAIDカードが取り付けてあるのでその関係かもしれません。
      ただ、RX590装着時には、このような設定は必要なかったのですが。

      スリープ復帰後の件ですが、AppleALC.kextは関係なかったようです。
      削除後も同様に黒画面のままの状態になってしまいます。
      現在もいくつか設定を試しておりますので、またご報告させていただきます、

      <key>Graphics</key>
      <dict>
      <key>Inject</key>
      <dict>
      <key>ATI</key>
      <true/>
      <key>Intel</key>
      <false/>
      <key>NVidia</key>
      <false/>
      </dict>
      </dict>

    • #7564 返信
      bootmacos
      キーマスター

      RTCのパッチは当ててあります? Gigabyte Z390 Designareだとスリープ復帰後のブラックスクリーンの原因になるようです。ASRockでも関係するかもです。

    • #7566 返信
      narihiro
      ゲスト

      bootmacos様

      ご返信ありがとうございます。

      申し訳ございませんが、RTCのパッチの当て方がわかりません、
      Kernel and Kext Patchhesの項目のApple RTCを選択すれば宜しいのでしょうか?

      よろしくお願いいたします。

    • #7567 返信
      bootmacos
      キーマスター

      失礼しました。こちらです。

      300チップセットマザーボードのRTC設定

    • #7569 返信
      narihiro
      ゲスト

      bootmac様

      現在の設定は下記のようになっております。
      置き換えたほうが宜しいのでしょうか?

      <dict>
      <key>Comment</key>
      <string>Fix AsRock Z390 BIOS DSDT Device(RTC) bug</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>oAqTU1RBUwE=</data>
      <key>Replace</key>
      <data>oAqRCv8L//8=</data>
      </dict>

    • #7572 返信
      narihiro
      ゲスト

      bootmacos様 匿名様

      全て解決いたしましたことをご報告いたします。

      先日Amazonで購入したPCI-Eの延長ケーブルが原因だったようです。
      Thermaltakeのケーブルを奮発したのですが、これがだめだったようです。
      https://www.amazon.co.jp/dp/B06WGRJSBK/

      上に書きましたように、”ATI Inject”にをtrueにしなくても動作するようになりました。
      スリープに関しましても短期の検証ですが問題ないようです。

      今回の件で得るものもございました。
      現在の状態では恐らく匿名様も音の問題があると上で書かれておりますが、
      私の環境でもノイズが出ます。
      そこで敢えて”ATI Inject”にをtrueにすることで、音の問題も無くなりました。
      システムレポートの”グラフィックス/ディスプレイ”項目の”リビジョンID”の下に
      “EFIドライバのバージョン”の項目が追加されます。
      RadeonVIIとRX590で共に確認できました。
      試されてみてはいかがでしょうか。

      この度は貴重なお時間をお付き合いいただきまして、
      誠にありがとうございました。
      今後もよろしくお願いいたします。

    • #7580 返信
      bootmacos
      キーマスター

      ライザーケーブルが原因とは思いつかないですね。動いておめでとうございます。

    • #7591 返信
      narihiro
      ゲスト

      bootmacos様 匿名様

      私もまさかライザーケーブルが原因とは思いませんでした。
      ただの延長ケーブルとの認識が甘かったようです。
      ご迷惑をお掛け致しました。

      お陰様で現在はトラブルなく動作しております。[SUCCESS]の状態です。

      お役に立てばと思いまして、現在のconfig.plistをUPしておきます。
      足りない箇所や、不要な箇所がありましたらご指摘をお願いいたします。

      この度は誠にありがとうございました。

      <?xml version=”1.0″ encoding=”UTF-8″?>
      <!DOCTYPE plist PUBLIC “-//Apple//DTD PLIST 1.0//EN” “http://www.apple.com/DTDs/PropertyList-1.0.dtd”&gt;
      <plist version=”1.0″>
      <dict>
      <key>ACPI</key>
      <dict>
      <key>DSDT</key>
      <dict>
      <key>Fixes</key>
      <dict>
      <key>AddMCHC</key>
      <false/>
      <key>FixHPET</key>
      <true/>
      <key>FixIPIC</key>
      <true/>
      <key>FixRTC</key>
      <true/>
      <key>FixShutdown</key>
      <true/>
      <key>FixTMR</key>
      <true/>
      </dict>
      <key>Patches</key>
      <array>
      <dict>
      <key>Comment</key>
      <string>Fix AsRock Z390 BIOS DSDT Device(RTC) bug</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>oAqTU1RBUwE=</data>
      <key>Replace</key>
      <data>oAqRCv8L//8=</data>
      </dict>
      <dict>
      <key>Comment</key>
      <string>change XHCI to XHC</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>WEhDSQ==</data>
      <key>Replace</key>
      <data>WEhDXw==</data>
      </dict>
      <dict>
      <key>Comment</key>
      <string>change XHC1 to XHC</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>WEhDMQ==</data>
      <key>Replace</key>
      <data>WEhDXw==</data>
      </dict>
      <dict>
      <key>Comment</key>
      <string>change EC0 to EC</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>RUMwXw==</data>
      <key>Replace</key>
      <data>RUNfXw==</data>
      </dict>
      <dict>
      <key>Comment</key>
      <string>change SAT0 to SATA</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>U0FUMA==</data>
      <key>Replace</key>
      <data>U0FUQQ==</data>
      </dict>
      </array>
      </dict>
      <key>DropTables</key>
      <array>
      <dict>
      <key>Signature</key>
      <string>DMAR</string>
      </dict>
      <dict>
      <key>Signature</key>
      <string>MATS</string>
      </dict>
      </array>
      <key>FixHeaders</key>
      <true/>
      <key>HaltEnabler</key>
      <false/>
      <key>SSDT</key>
      <dict>
      <key>Generate</key>
      <dict>
      <key>PluginType</key>
      <true/>
      </dict>
      </dict>
      </dict>
      <key>Boot</key>
      <dict>
      <key>Arguments</key>
      <string>darkwake=8</string>
      <key>DefaultVolume</key>
      <string>Macintosh HD</string>
      <key>Timeout</key>
      <integer>5</integer>
      <key>XMPDetection</key>
      <string>Yes</string>
      </dict>
      <key>Devices</key>
      <dict>
      <key>Audio</key>
      <dict>
      <key>Inject</key>
      <integer>1</integer>
      <key>ResetHDA</key>
      <true/>
      </dict>
      <key>Properties</key>
      <dict>
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
      <dict>
      <key>AAPL,ig-platform-id</key>
      <data>AwCSPg==</data>
      <key>device-id</key>
      <data>kj4AAA==</data>
      <key>framebuffer-patch-enable</key>
      <data>AQAAAA==</data>
      <key>framebuffer-stolenmem</key>
      <data>AAAwAQ==</data>
      </dict>
      </dict>
      <key>USB</key>
      <dict>
      <key>FixOwnership</key>
      <true/>
      </dict>
      </dict>
      <key>GUI</key>
      <dict>
      <key>Scan</key>
      <dict>
      <key>Entries</key>
      <true/>
      <key>Tool</key>
      <true/>
      </dict>
      <key>Theme</key>
      <string>embedded</string>
      </dict>
      <key>Graphics</key>
      <dict>
      <key>Inject</key>
      <dict>
      <key>ATI</key>
      <true/>
      <key>Intel</key>
      <false/>
      <key>NVidia</key>
      <false/>
      </dict>
      </dict>
      <key>KernelAndKextPatches</key>
      <dict>
      <key>AppleIntelCPUPM</key>
      <false/>
      <key>KernelPm</key>
      <true/>
      <key>KextsToPatch</key>
      <array>
      <dict>
      <key>Comment</key>
      <string>USB Port Limit Patch 1 PMHeart/DalianSky</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>g/sPDw==</data>
      <key>InfoPlistPatch</key>
      <false/>
      <key>MatchOS</key>
      <string>10.15.x</string>
      <key>Name</key>
      <string>com.apple.iokit.IOUSBHostFamily</string>
      <key>Replace</key>
      <data>g/s/Dw==</data>
      </dict>
      <dict>
      <key>Comment</key>
      <string>USB Port Limit Patch 2 PMHeart/DalianSky</string>
      <key>Disabled</key>
      <false/>
      <key>Find</key>
      <data>g/kPDw==</data>
      <key>InfoPlistPatch</key>
      <false/>
      <key>MatchOS</key>
      <string>10.15.x</string>
      <key>Name</key>
      <string>com.apple.driver.usb.AppleUSBXHCI</string>
      <key>Replace</key>
      <data>g/k/Dw==</data>
      </dict>
      </array>
      </dict>
      <key>RtVariables</key>
      <dict>
      <key>BooterConfig</key>
      <string>0x28</string>
      <key>CsrActiveConfig</key>
      <string>0x3E7</string>
      <key>MLB</key>
      <string>C02726902CDH69F1M</string>
      <key>ROM</key>
      <string>UseMacAddr0</string>
      </dict>
      <key>SMBIOS</key>
      <dict>
      <key>Family</key>
      <string>iMac</string>
      <key>Manufacturer</key>
      <string>Apple Inc.</string>
      <key>Mobile</key>
      <false/>
      <key>ProductName</key>
      <string>iMac19,1</string>
      </dict>
      <key>SystemParameters</key>
      <dict>
      <key>InjectKexts</key>
      <string>Yes</string>
      <key>InjectSystemID</key>
      <true/>
      </dict>
      </dict>
      </plist>

    • #7596 返信
      bootmacos
      キーマスター

      config.plistありがとうございます。アップロード失敗部分は削除しておきました。

15件の返信スレッドを表示中
返信先: [そこそこSUCCESS]ASrock Phantom GAMING 6,ASRock RADEON VII, GIGABYTE GC-TITAN RIDGE
あなたの情報: