[Help!]catalinaでのVEG64の性能

ホーム フォーラム Discussions [Help!]catalinaでのVEG64の性能

  • このトピックには17件の返信、1人の参加者があり、最後にeraserにより8ヶ月前に更新されました。
17件の返信スレッドを表示中
  • 投稿者
    投稿
    • #7517 返信
      eraser
      ゲスト

      以前、以下の構成でBUILDした者です。

      [Success]i9 9900k,ASRock z390 Phantom Gaming itx,Radeon 590,Mojave

      GPUをRX590→RX5500と変更し、最終的にVEGA64と入れ替えました。
      メーカーはPowerColor、リファレンスモデルです。

      Geekbenchを回したところ、OpenCLで45410、Metalで52846と他で見たスコアより
      明らかに低く、解決策を探しています。

      BIOSスイッチは通常、VGTabでファンコントロールのkextを作成し入れています。

      catalinaでの動作仕様なのか、解決策があるのか、情報をお持ちの方にご意見を頂けると幸いです。

    • #7519 返信
      kanagu
      ゲスト

      Geekbenchのバージョンにもよるかと思いますが、Ver5であればそんなもんだと思います。
      当方RadeonVIIですが、
      OpenCL 48921
      https://browser.geekbench.com/v5/compute/406282
      Metal 52422
      https://browser.geekbench.com/v5/compute/406287
      です。VEGA64と変わらない…
      Ver4とは数値的には全く別と考えた方がいいみたいです。

      でも実際にPremiereやDaVinci Resolveで動画のエンコーディングに使ってみると(OpenCL)、VEGA FE(VEGA64のメモリ16GBタイプですね)を使っていた頃よりRadeonVIIの方が差を体感できる程度に速いです。
      ゲームはしないのでわかりません。。

      参考になれば…
      では良い○acintoshライフを〜

    • #7520 返信
      bootmacos
      キーマスター

      確かに手元の測定よりは少し低いですね。

      Radeon RX580/Vega 64/5700XTの性能を比較

      Dual BIOS Toggle Switchとやらがあるそうですが、これはPrimaryになっていますでしょうか。Secondaryになっていると10%ほど性能低下するようです。

    • #7526 返信
      eraser
      ゲスト

      kanaguさま、bootmacosさま

      コメントありがとうございます。

      SwitchはPrimaryになっているんですよね…。

      RX590を同じcatalina(10.15.2)環境で使っていた時のスコアとほぼ変わらない数値なので、
      他の方のスコアも見るにちょっと解せない状況で。

      BIOSも一旦クリアしたりしてみて試しているのですが解決できていません。

      海外のフォーラムを見ると、Mojaveの頃から同じような症状はあるみたいなのですが
      解決したとの報告が見つけられず八方塞がりです。

      特定のシリアルのボードとの相性なのか、メーカーとの相性なのか、
      bootmacosさんと同じくらいのスコアが出るといいのですが。。。

    • #7527 返信
      mk
      ゲスト

      よくはわかりませんが、vegaは発熱が減れば減るほどクロックが勝手に上がる気がします。
      以前、vega64のスコアがイマイチだったので分解してみたところ、グリスがパリパリに乾いていたのでクマグリスに塗り替えて、ケースのほうもエアフローを見直し、設定でunder voltageしたらスコアが上がりました。WindowsのHwinfoで確認したところcoreTempが95℃くらいだったのが85℃ほどに下がって、動作クロックも上がっていたのでなんらかの関係があるような。。。
      メモリが105℃くらいでダレ始めるようにも思いますが、正直なところよくわかっていません(´ω`*)

      itxケースをお使いのようですので一度温度をチェックされてみてはいかがでしょうか。

    • #7528 返信
      mk
      ゲスト

      試しに最新版のGeekBench5.1.0を落としてきてVIIでやってみました。

      OpenCL 35264
      https://browser.geekbench.com/v5/compute/409936
      Metal 50203
      https://browser.geekbench.com/v5/compute/409957

      ん?ありゃ???
      kanaguさんと同じような構成ですがスコア出てないようです。。。

      どうやら温度とかの問題でもないのかもしれませんね。

    • #7531 返信
      eraser
      ゲスト

      mkさま

      コメントありがとうございます。

      温度に関しては四苦八苦していて、色々試行錯誤しております。。。
      折を見てグラボのグリスも塗り直してみようかと。
      未使用品を購入したのですが、とはいえ2年以上前の製品ですし。

      中古の同じメーカーの64でも試したのですがほぼ同じスコアでした。
      bootmacosさんの64はOCモデルだっと思いますので、その辺がスコアの違いに出ているのでしょうか?
      試しにVGTabでクロックをいじってみたら、OpenCLで47000台まで上がりました。

      とはいえ、Ⅶでのスコアを見ると原因はそればかりではなさそうですね。
      性能的には十分なので使用する分にはいいのですが、なんだか気分的にすっきりしないです。

    • #7532 返信
      mk
      ゲスト

      eraserさん

      たしかに使う分には問題ないんですが、気分的にスッキリしないですね。。。

      試しに同じマシンのWindowsで試してみました。

      OpenCL 88493
      https://browser.geekbench.com/v5/compute/412949
      Vulkan 70724
      https://browser.geekbench.com/v5/compute/412950

      単純にMacと比較はできないでしょうけど、OpenCLで倍以上でてます。。。

      ただ、davinci resolve とかで使ってる分には体感上はあまり変わらない気もしますが。。。

      関係ありませんが、Windows版のGeekBenchのUIのショボさに(*´Д`)

    • #7545 返信
      eraser
      ゲスト

      その後色々と試してみましたが結果は変わりませんでした。
      VEGA64だけでなく、radeonⅦでのGeekbenchのスコアを見てみると
      windowsに比べてだいぶ低いスコアが出ているので何かしらOS側で制限をかけているのでしょうか?

      5700を始め新しい世代のGPUもあまりスコアが出ていないので、
      OSのアップデートで性能面での最適化がされるといいのですが…。
      (5000番台に関しては演算より描画に重きを置いているようなのでGeekbenchのようなベンチソフトだと
      低いスコアが出るのは別の問題かもしれませんが)

      Geekbench基準だとrx580あたりがベストバランスなのかもしれませんね。

    • #7557 返信
      bootmacos
      キーマスター

      単なる推測ですが、VEGA 64やRadeon VIIはフルサポートされていないのではないかと思います。実機で使われている64やVIIは、Pro等の名前がついたApple社向け特別仕様版なので、それには対応しているものの、一般向け製品版では少し違うところがあって、動作はするものの性能が出ていないのではないかと想像してます。それに対して、RX580は、Thunderbolt接続eGPUボックス開発キットに搭載されていたので、ある程度最適化が進んでいるのではと思います。

    • #7561 返信
      eraser
      ゲスト

      bootmacosさま

      確かにそう考えると合点がいきます。
      5700、5500も同様な傾向があるようなので、gpu選びはスペックよりも相性が重要ですね。
      Hackintoshだけでなく、外付けのegpuを使うことを考えると、ドライバのアップデートでもう少し最適化してもらえるといいのですが。。。

    • #7585 返信
      eraser
      ゲスト

      紆余曲折あってvega64からradeonⅦに置き換えました。

      GeekbenchだとopenCLで45000程度と低調ですが、LuxMarkだとwindows並みのスコアが出て、
      GPU使用率も100%に張り付くので、もしかするとGeekbenchとの相性の問題かもしれませんね。
      (嘘か本当かわかりませんが、海外のフォーラムでもGeekbenchはハイエンドカードとの相性が悪いとの書き込みがありました。)

      CaptureOneでもGPU使用率は上がらないので、ソフト側の最適化の問題、もしくは処理に必要とされる計算能力との相性の問題のような気もします。

      どちらにしろオーバースペックで宝の持ち腐れ感は否めませんが、、、

    • #7599 返信
      bootmacos
      キーマスター

      確かにGeekbenchの問題なのかもしれないですね。

      オーバースペックとか、宝の持ち腐れとか言ってしまうと、自作PC民はほぼ全滅な気がします。気にせず頂点を目指しましょう😀

    • #7613 返信
      eraser
      ゲスト

      bootmacosさま

      確かにそうですね。

      自分の中ではi9にradeonⅦでいくところまで行ったので、とりあえずはひと段落して使い倒していこうと思います。

      最初は必要十分なそこそこの性能で、と思っていたのですがだんだん欲が出てくるのも自作の面白さだと思います。
      見てくれも、数値上の性能も気になってしまうのは人の性ですかね。。。

      一応掲示板の趣旨もあるので、現状の状況を書いておきます。

      ▪️iGPU
      有効にするとスリープの挙動がおかしくなるのでOFFで使っていたのですが、OFFにするとGPUの性能低下を招くという情報もあって色々と弄ってみました。
      確証はないのですが、BIOSのCSM設定をいじっていたらスリープが安定したのでそこらへんと関係があるかもです。
      GPUのGeekbenchスコアは多少ですが改善しました。(43,000台→45,000台)

      ▪️SMBIOS
      MacPro1.1にするとradeonⅦの性能が出るとの情報を見て試してみましたが、変化はありませんでした。
      CPU温度が読めなくなってしまったので、CPUとの相性も考えてiMac19.1に戻して運用しています。

      以前掲載されていたMac Pro実機でのradeonⅦのスコアと同等の数値が出ているので、Geekbenchのスコアは現状では致し方ないと考えて納得することにします。

      次のOSアップデートで5000番台含めパフォーマンスが改善することを願っています。

    • #7618 返信
      bootmacos
      キーマスター

      表示に使っていないiGPUも、それに合わせた設定をすると良いようです。手元のマシンは、WhateverGreenにお任せで何もしていませんが。

      Liluとプラグイン:(1) WhatEverGreenの使い方

    • #7624 返信
      eraser
      ゲスト

      僕もWEG任せでid等の設定はいじっていませんです。

      Intel Power GadgetでGFX項目が表示されているのとGeekbenchのYour deviceの項目でCPU 1にIntel UHD Graph cs 630が表示されているのでiGPUがheadlessで動いていると思っているのですがどうなんでしょうか?

      設定をいじりだすとsleepなど他のところに不具合が出そうで、うまく動いている間はなかなか挑戦できないのが本音です。。。

    • #7628 返信
      bootmacos
      キーマスター

      そうですね。手元のマシンも、Geekbenchで同様に表示されて、問題が無いので放置してあります。参照した記事によると、IORegistryExplorerでIGPUを検索して、AAPL, ig-platform-idプロパティ(バイト順が逆になっています)が、以下の値になっていればヘッドレスになっているようです。

      Coffee Lake CPU
      9th Gen UHD-630 IGPU = 0x3E980003 (MacOS 10.14.4+で使用)
      8th Gen UHD-630 IGPU = 0x3E920003 or 0x3E910003 (MacOS 10.13.6 〜 10.14.Xで使用)
      Kaby Lake CPU
      HD-630 IGPU = 0x59120003 (MacOS 10.13.Xで使用)
      Unknown = 0x59180002 (推奨しません)
      SkyLake CPU
      HD-510 IGPU = 0x19020001
      GT2f IGPU = 0x19170001
      HD-530 IGPU = 0x19120001
      Iris Pro 580 = 0x19320001
      Haswell CPU
      HD-4600 IGPU = 0x0412000B or 0x04120004
      Ivy Bridge CPU
      HD-4000 IGPU = 0x01620006 or 0x01620007
      Sandy Bridge CP
      HD-3000 IGPU = 0x00030030

      • この返信は8ヶ月前にbootmacosが編集しました。
      • この返信は8ヶ月前にbootmacosが編集しました。
    • #7643 返信
      eraser
      ゲスト

      bootmacosさま

      IORegistryExplorerで確認してみたところ、ig-platform-idが違うidになっていたので
      Clover Configuratorで置き換えてみました。

      Geekbenchのスコアは変わりませんが、処理の時間が3秒程度早くなったようです。
      (誤差の範囲かもしれませんが…)

      情報ありがとうございました!

17件の返信スレッドを表示中
返信先: [Help!]catalinaでのVEG64の性能
あなたの情報: