[Success]10900k,ASUS ROG STRIX Z490-I,Radeon Ⅶ

ホーム フォーラム User Builds [Success]10900k,ASUS ROG STRIX Z490-I,Radeon Ⅶ

  • このトピックには5件の返信、1人の参加者があり、最後にeraserにより3日前に更新されました。
5件の返信スレッドを表示中
  • 投稿者
    投稿
    • #10951 返信
      eraser
      ゲスト

      mini-itxで9900kから換装しました。

      ■構成
      CPU:Intel core i9 10900k
      Motherboad:ASUS ROG STRIX Z490-I
      GPU:Radeon Ⅶ
      Memory:Corsair VENGEANCE 32GB×2 @3200MHz
      Power Supply:Corsair SFX 750w
      Cooler:EK water cooling 240×45mm Radiator(CPU+GPU)
      Case:STREACOM DA2

      MacOS:10.15.7(19H2)
      Bootloader:OpenCore 0.6.2

      ■ACPI
      SSDT-RHUB.aml
      SSDT-PLUG.aml
      SSDT-EC.aml
      SSDT-AWAC.aml

      ※SSDT-EC-USBX.amlだとブート時にスタックしてしまうためSSDT-ECに入れ替えました。

      ■kext
      WhateverGreen.kext
      VirtualSMC.kext
      USBPorts.kext
      SMCSuperIO.kext
      SMCProcessor.kext
      RadeonBoost.kext
      Lilu.kext
      IntelMausi.kext
      FakePCIID.kext
      FakePCIID_Intel_I225-V.kext
      AppleALC.kext

      ■Drivers
      OpenRuntime.efi
      OpenCanopy.efi
      HFSPlus.efi

      ■動くこと
      sleep
      shutdown
      iGPU
      Ethernet

      ■動かないこと
      Bluetooth
      WiFi
      再起動時にBIOS起動前にスタックします

      ベンチマークのスコアを見るとパフォーマンス的には過不足なく動いているようです。熱を覚悟していたのですが、マザーボードの制御のおかげか(以前のZ390はAsRock製)、ヒートスプレッダの改良によるものか、はたまたあたり石なのか、9900kよりも低い温度で動いています。offsetで0.08V電圧を下げて、CinebenchR20が70度以下で回ります(スコアは6500程度)。

      wifiとBluetoothのネイティブ駆動は諦めて、水温計が接続できて水温でポンプ制御ができるASUSのマザーにしてみました。インテルのカードが動くkextがあるようなので試してみようと思います。

      一点不具合があって、再起動をかけるとBIOS起動前にスタックしてしまいます。BIOSの設定なのか、マザー側の問題のような気もするのですが、知見をお持ちの方がいらっしゃいましたらアドバイスをいただけると助かります。通常のシャットダウンと起動では問題なく動作します。

      CPUとマザーの置き換えだったので気楽に考えていたのですが、起動できるまで結構ハマりました。。。ACPIとかkextとか、不備や過不足があればご指摘お願いします!

    • #10958 返信
      bootmacos
      キーマスター

      動作おめでとうございます。
      手元のマシンもASUS ROG STRIX Z490-G + 10900Kなので、類似点がある気がします。でも、本格水冷でGPUまで冷却されているのですね。ちょっとすごい。

      RadeonBoost.kextは色々不具合が出るという噂で、使っていませんがどうでしょうか。Big Sur beta 9で5700XTの速度がかなり改善したので、Big Surに移行したらRadeon VIIも素で高速になるかもしれないです。

      手元ではSSDT-EC-USBX.amlで動いています。また、こちらの対応表ではSSDT-EC-USBX.amlが必要となっているようです。
      https://dortania.github.io/Getting-Started-With-ACPI/ssdt-platform.html#desktop

      このマザボのBT/WiFiソケットはCNVi専用のようですが、SSD用のM.2に取り付けるのも可能かと思います。ただ、このマザボはM.2が二階建てなので、難しいのかな。

      Z490マザボ搭載WiFiをmacOS対応品に交換する

      再起動で失敗するのは謎ですね。ASUS ROG STRIX Z490-Gは、BIOSの設定を色々変えていると、時々、ブートドライブBIOS設定が消えてしまうことがあります。設定しなおして、OpenCoreのブート画面でNVRAMをクリアすると治ります。普通に使っている限りは問題ないので放置しています。

    • #10963 返信
      eraser
      ゲスト

      bootmacosさま

      コメントありがとうございます。

      radeon Ⅶのファンが動画書き出し時などにうるさくて、CPUとまとめて水冷にしました。
      本格水冷といってもソフトチューブで適当に繋げて押し込んでいるだけなので見栄え的にはあんまりなのですが。。。
      筐体が小さいのでリザーバーとポンプを押し込むのに苦労しました。
      ケースデカくすれば済む話なんですけど、そこら辺は完全に趣味の世界ですね笑

      Radeonboost.kextは手元では特に不具合はないんですけど、無しで性能が上がるといいですね。Big Surに期待します。

      SSDT-EC-USBX.amlとSSDT-EC.amlって並列して入れていいものなのでしょうか?一応両方入れても動くみたいなので、しばらく両方入れて様子を見てみようと思います。

      wifiはご指摘のようにM.2のスペースが狭いので諦めました。intelのカードが動くか試してみてまたご報告します。

      再起動問題が解決できるといいのですが、BIOSアップデートしたり色々設定をいじっているのですが改善の兆しが見えません、、、初期不良なのかな?

    • #11054 返信
      eraser
      ゲスト

      その後のご報告です。

      intelのwifiカードですが、一応動きました。既知の情報かもしれませんが。

      ■wifi

      itlwmx.kext+HeliPort.app

      kextをインジェクトして、HeliPortというアプリを入れるとwifiが動きます。
      速度はちょっと遅めな感じはします。
      ログイン項目で指定して起動時に立ち上げれば不自由なく使えそうです。

      ■Bluetooth
      IntelBluetoothFirmware.kext
      IntelBluetoothInjector.kext

      kextをインジェクトすればそのままBluetoothが使えました。
      手元の環境だけの検証ですが、機種を20,2に指定すると動くのですが20,1だと動きませんでした。
      なんでしょうね…?(動作検証中だったので他のkext等が影響しているかもしれません)

      Continuityの諸々の機能は使えないので寂しさはありますが、マザーボードをいじらずに両機能が使えるのは嬉しいです。
      手元の環境だと拡張カードを追加する余裕もないので、itxの宿命ですね。。。
      普段の使用環境だとBluetoothが動けば特に問題はないので、これで納得することにします。

      ■再起動時の不具合

      どうやらGPU周りの接触不良だったようです。
      ケースとグラボの相性で、元々DPケーブルが根元まできちんと刺さらなかったのですが、マザーボードの変更でそこが悪化したようで。

      最近のマザボに多いバックパネル一体構造のおかげで、GPUのバックパネルが当たって無理やり押し込んでいたのですが
      これもいけなかったようです。
      EKの厚みのあるバックパネルから元のバックパネルに戻したところ再起動できるようになりました。
      水冷のチューブを結構無理やり押し込んでいるのも影響したのかもしれません。

      グラフィック周りの不具合を示すランプがついていたのでRadeonBoost.kextを疑ったりしたのですが、物理的な要因だったみたいです。とはいえ通常起動時は起動していたのでそこら辺が解せないのですが。。。ASUSのマザボはそこら辺がセンシティブなんですかね?

      ■OSクラッシュ

      そんなこんなの検証中に再起動と強制電源OFFを繰り返していたらOSがクラッシュしました。SSDを外して別のMacでバックアップを取ったのですが、OSのパーティションのほうに昔使っていたcloverの残骸のファイルが残っていたりして、SSDをフォーマットしてからインストールし直した方が良かったかなと反省しました。再インストール後はSSDT-EC.amlなしで起動するようになりました。

      その後AppStoreのen0問題に悩まされたりしながら、CPUの載せ替えと言えども、順を追って一から丁寧にやった方がいいと痛感した次第です。

      ■水冷の運用について
      ASUSのマザーボードの温度センサー端子に、ラジエーター排出後の温度センサー情報を送ってポンプ、ファンの速度を調整しています。
      CPU、GPUが同じ水路で冷やされているので、以前はDavinciの書き出しなどGPUメインの動作の時にCPU温度に影響が出るまでファンが動き出さなかったのですが、GPUの発熱にも反応してくれるようになったので安心感があります。

      水温が上がるまではCPU温度が上がってもファンが動かないので静かでいいです。水温が上がれば一緒なんですけど笑。

      ■10900k

      そんなに変わらないかなと思っていたのですが、9900kに比べて体感できるくらいにはサクサクしています。マザボの影響かもしれませんが、思ったより発熱も穏やかで、変えて良かったなと思っています。

      現状では全体に不具合なく動くようになりましたが、油断した時に不具合の再発とか起きそうな気もするので、気長に付き合って行こうかなと思っています。

    • #11061 返信
      bootmacos
      キーマスター

      HeliPortなしでも動くようになったらしいですね。

      続・macOSでIntel WiFiを使う(itlwm) from hackintosh_ja

    • #11084 返信
      eraser
      ゲスト

      Airportitlwm使ってみました。

      通常のwifi同様、起動とともにwifiが繋がります。

      すごいですね。。。

      今まで見えていなかったAirDropの項目がFinderに出現しました。
      どうやらまだ動かないみたいですが、OS側からネイティブなwifiとして認識されているみたいなので今後に期待します。

5件の返信スレッドを表示中
返信先: [Success]10900k,ASUS ROG STRIX Z490-I,Radeon Ⅶ
あなたの情報: