[HELP] GIGABYTE H370 HD3+8700+Vega56」

ホーム フォーラム User Builds [HELP] GIGABYTE H370 HD3+8700+Vega56」

このトピックには37件の返信が含まれ、2人の参加者がいます。1 ヶ月、 2 週間前に  kj107 さんが最後の更新を行いました。

  • 投稿者
    投稿
  • #5538 返信

    kj107

    マザーボード GIGABYTE H370 HD3
    CPU Core i7 8700
    ビデオカード SAPPHIRE Pulse Radeon RX Vega56 8GB HMB2
    メモリ CORSAIR DDR4-2666MHz VENGEANCE LPX Series 8GB×4枚 CMK16GX4M2A2666C16
    2.5インチ SSD 500GB / WD Blue 3D WDS500G2B0A
    OS macOS Mojave 10.14.0

    この組み合わせで Hacintosh しようとしています
    Cloverで起動ディスクを選択する画面までは進むのですが
    Install USB メモリ を 選択してすぐに 進入禁止マークが表示されてしまします。

    私がinstall USB を作る手法としては Tonymac86 さんの UniBeast9.2.0を使って
    BootUSBを作って EFI/CLOVER/CLOVERX64.efi と config.plist を デスクトップ等へ 保存
    その後 Clover_v2.4k_r4898 を使用して

    ApfsDriverLoder-64.efi
    AppleImageCodec-64.efi
    AppleKeyAggregator-64.efi
    AppleUITheme-64.efi
    AppleMemoryFix-64.efi
    DataHubDxe-64.efi
    EmuVariableUefi-64.efi
    FirmwareVolume-64.efi
    FSInject-64.efi
    PartitionDxe-64.efi
    SMCHelper-64.efi
    VBoxHfs-64.efi
    HFSPlus
    OsxAptioFix3dDrv-64
    OsxAptioFixDrv-64
    OsxFatBinaryDrv-64

    を インストール します

    追加で EFI/CLOVER/kexts/Other に

    AppleALC.kext
    BrcmFirmwareData.kext
    BrcmPatchRAM2.kext
    FakePCIID_Broadcom_WiFi.kext
    FakePCIID.kext
    FakeSMC.kext
    GenericUSBXHCI.kext
    IntelMausiEthernet.kext
    Lilu.kext
    realtekALC.kext
    RealtekRTL8111.kext
    USBInjectAll.kext
    VoodooHDA.kext

    を入れ
    EFI/CLOVER/drivers64UEFI/OsxAptioFix2Drv-free2000.efi

    Clover_v2.4k_r4898 を使って 作られた EFI/CLOVER/CLOVERX64.efi と config.plist を

    を追加したあと UniBeast9.2.0 で 作られた
    CLOVERX64.efi と config.plist に 置き換えます。

    このやり方で マザーボード GIGABYTE H370 HD3 の
    microATX版の H370M D3H M-ATXマザーボード+CPU Core i3 8100 との 組み合わせでは
    Hacintosh Mojave 10.14.0 が 上手く行ったのですが

    ビデオカード SAPPHIRE Pulse Radeon RX Vega56 8GB HMB2 を 追加したのが原因?なのか
    Clover の 起動画面で Install USB を 選択して すぐに 進入禁止マークで 止まってしまします。

    どなたか お力添え 頂ければ幸いです
    宜しくお願いいたします。

  • #5540 返信

    脱Sandyおじさん

    VEGAの問題でなくマザボのUSBの15個のポートリミットに引っかかっているので、USBが認識してないのではないでしょうか。 config.plistにポートリミット制限を外す記述を追加しましょう。

    USBポートを設定する

    https://www.tonymacx86.com/threads/mojave-10-14-5-port-limit-removal-patch.277166/

  • #5541 返信

    bootmacos
    キーマスター

    起動後すぐに禁止マークが出るということですので、おそらくはカーネルを読み込むメモリー領域が確保できていないことが原因だと思います。-vオプションで起動すればメモリーアロケーションに失敗したというようなメッセージが出ていると思います。

    もしそうでしたら、メモリー領域を確保するefiファイルの不調です。実施された手順がややこしいので間違っているかもしれませんが、書かれている手順によると、EFI/CLOVER/drivers64UEFI/フォルダの中に、

    • OsxAptioFix3dDrv-64.efi
    • OsxAptioFixDrv-64.efi
    • OsxAptioFix2Drv-free2000.efi

    の3個が入っているように読み取れますが、このやり方は正しくありません。これらはどれも、連続したメモリー領域を確保するためのefiファイルで、必要なのは一つだけで、複数を入れると、どれか一つが動作することになります。どれが動作するかは予測できないです。一つひとつ試してどれを使った場合に安定して起動できるか調べます。複数の候補がある場合は、

    1. AptioMemoryFix.efi
    2. OsxAptioFix3Drv-64.efi
    3. OsxAptioFix2Drv-64.efi
    4. OsxAptioFixDrv-64.efi
    5. OsxAptioFixDrv-free2000.efi
    6. OsxLowMemFixDrv-64.efi

    の優先順位で選びます。300シリーズチップセットのMSIとASRockのマザボだとOsxAptioFixDrv-free2000.efiじゃないと動かない場合が多いらしいですが、GigabyteならAptioMemoryFix.efiで動くかもしれません。

    詳しくはこちらを読んでください。

    Cloverインストーラの設定

  • #5542 返信

    bootmacos
    キーマスター

    もう一点、この手順で気になったことがあります。書かれた手順によると

    1. UniBeast9.2.0をインストール
    2. CLOVERX64.efiとconfig.plistをバックアップ
    3. Clover_v2.4k_r4898をインストール
    4. バックアップしてあったCLOVERX64.efiとconfig.plistを戻す

    と読めますがこの理解で正しいでしょうか。だとするとCLOVERX64.efiとconfig.plistをバックアップして戻すのは意味がないです。Cloverをアップデートするときにはすでにあるconfig.plistが書き換えられることはありませんし、この手順だとCLOVERX64.efiのバージョンが上がらないです。Cloverを初めてアップデートするときには、現在入っているefiファイルが選択されるようにカスタムインストールする必要はありますが、あとは現状を保存してくれるのでバックアップする必要はないと思います。

  • #5549 返信

    kj107

    bootmacos さん 回答ありがとうございます。

    >1.UniBeast9.2.0をインストール
    >2.CLOVERX64.efiとconfig.plistをバックアップ
    >3.Clover_v2.4k_r4898をインストール
    >4.バックアップしてあったCLOVERX64.efiとconfig.plistを戻す

    は この手順で行っています、
    理由としては Clover の どのバージョンを使っても上手く起動することが出来なかったので
    たまたま、偶然 UniBeast9.2.0 で作られた CLOVERX64.efiとconfig.plist を
    Clover_v2.4k_r4898 で 作られた CLOVERX64.efiとconfig.plist と 入れ替える事によってのみ
    macOSのインストール 及び インストールディスクからの 起動が出来るようになったのです。
    (どうして これを 入れ替えようと 思ったのか? は 思い出せませんけれど)

    ビデオカード SAPPHIRE Pulse Radeon RX Vega56 8GB HMB2 を動かすには

    Clover の設定とか インストールする ドライバ ファイル は 特に必要は無いのでしょうか?

    とのかく メモリ系ドライバ.efi の 選別を 行ってみたいと思います。

    ありがとうございました。

    出来たらまたご報告させて頂きたいと思います。

    -vオプション や config.plist の書き換え方 は 全く解りませんので とりあえず -vオプションの
    使い方を探してみたいと思います。

    Clover だけで Install USB を 作る場合は 普通は どういう過程で Install USB を 作るのでしょうか?
    前もって 本物のMac用の Install Boot USB を 作って その上で
    Clover を使って 各ドライバ や .kext を 入れていくものなのでしょうか?

    まっさらな USBメモリに GUIDパーティーション とMacOS Journaled 形式でフォーマットして
    そこにCloverを使って ドライバ等を インストールしても 肝心の macOS の インストーラーは
    Clover で作った USBメモリ内には 入っていないと 思うのですが。

    • #5554 返信

      bootmacos
      キーマスター

      CloverだけでInstall USBを作る場方法は以下です。通常は後半のステップで試行錯誤します。

      1. USBメモリをフォーマットする
      2. 配布されているmacOSインストーラの中にあるcreateinstallmediaコマンドでUSBメモリをmacOSインストーラにする(これは普通のMacで起動できてクリーンインストールできる)
      3. CloverをUSBメモリにインストールする(.efiファイルもインストールされる)
      4. 必要なkext類をUSBメモリ内のEFI/CLOVER/kexts/Otherにコピーする
      5. USBメモリ内のEFI/CLOVER/config.plistを環境に合わせて編集する

      詳細はこちらをご覧ください。

      High Sierra導入用USBメモリ作成方法

      • この返信は2 ヶ月、 4 週間前に  bootmacos さんが編集しました。
    • #5651 返信

      bootmacos
      キーマスター

      Clover だけで Install USB を 作る場合は 普通は どういう過程で Install USB を 作るのでしょうか?
      前もって 本物のMac用の Install Boot USB を 作って その上で
      Clover を使って 各ドライバ や .kext を 入れていくものなのでしょうか?

      こちらをご覧ください。High Sierraの時に書いた記事ですが、Mojaveでも同じはずです。

      High Sierra導入用USBメモリ作成方法

  • #5558 返信

    kj107

    お世話になります

    こちらの記事を参考に 色々やってみましたが 上手く 行きませんでした

    Radeon RX Vega 64をmacOSで使う

    で、基本に帰り ビデオカードを 外して Hacintosh に 成功した
    Boot USB で やってみましたが やはり ダメでした。

    >H370M D3H M-ATXマザーボード+CPU Core i3 8100

    同じメーカーの H370チップセットでも CPU が Core i7 8700 だったりと
    ちょっとした違いでも FEI を 変更しないとダメなようですね。

    Vega64 の 方の 記事通りに .kext や efi ドライバを 変更してみたら
    Clover での 起動ディスク選択 画面から リンゴマークが表示され 進行を示す バーが
    だいぶ進むようにはなったのですが(バーが中程まできます) 最後まで読み切れず
    侵入禁止マークが出てしまいます。

    • #5590 返信

      bootmacos
      キーマスター

      -vオプションで起動するとどのようなエラーが出ますか?また、現在のefiファイル類と、kextファイル類の構成はどのようになっていますでしょうか。config.plistの内容はどうなってますでしょうか。そういう情報があると原因がわかるかもしれません。

  • #5606 返信

    さうすうぇすと

    USB Installを行う際に残り時間2分程でプログレスバーが進まなくなり、禁止マークが出る問題ですが、
    UEFIで
    Chipset → Above 4G Decoding → Disabledを設定すると上手く行くかもしれません。

    私のマザーボードはZ390 Aorus proですが、こちらを設定することでInstallerが完走しました。
    ※残り2分の表示からかなり時間はかかると思います。
    ※当設定項目はGigabyte-Z390固有か否かは不明です、お使いのマザーボードの設定で表示されない場合はご容赦下さい。

    こちらのインストールガイドに上記設定について記載がありますので、宜しければご参考になさって下さい。
    https://www.insanelymac.com/forum/topic/337837-glasgoods-macos-mojave-successguide-for-aorus-z390-pro/

  • #5607 返信

    kj107

    さうすうぇすと ご指導ありがとうございます。

    最初に Hcintosh に 思考したマザーボード

    >H370M D3H M-ATXマザーボード+CPU Core i3 8100

    にはなくて、今回 Hacintosh しようとしている マザーボードに追加されているのは

    Radeon RX Vega56 ビデオカード の 他に

    intelのオプテェインメモリー として 16BG の データ保存 HDD の キャッシュとして M.2 SSD が 着いています

    これも 上手く行かない要因の一つ?でしょうか。
    (キャッシュ効果は 殆ど無いのですが HDD と M.2 SSD と RAID を 組む形での 構成になるので
    BIOS で 切り離しただけでも Windows が 壊れてしまいます。 機能をOFFする事が 簡単に出来るのなら良いのですが)

    今は上手く Hacintosh に 成功した マザーボード

    >H370M D3H M-ATXマザーボード+CPU Core i3 8100

    に Radeon RX Vega56 を 取り付けて 試しております。

  • #5608 返信

    kj107

    bootmacos さま いつも 恐縮です。

    Clover -V オプション なのですが、自分なりに検索してみたのですが
    -v オプション が 検索に 引っかかりません。

    -v オプションの 使い方について 参考文献が ありましたら ご紹介くださいますよう
    宜しくお願いいたします。

    • #5609 返信

      bootmacos
      キーマスター

      config.plistのBoot, Argumentsに” -v”を追加します。例えば以下のように。

      <key>Boot</key>
        <dict>
          <key>Arguments</key>
          <string>uia_exclude=HS01;HS03;HS04 -v</string>

      またCloverの起動画面の下のOptionメニューから起動オプションを選べば一時的に-vを追加することもできます。

      • この返信は2 ヶ月、 4 週間前に  bootmacos さんが編集しました。
      • この返信は2 ヶ月、 4 週間前に  bootmacos さんが編集しました。
  • #5618 返信

    kj107

    お世話になります

    さうすうぇすと さま

    >Chipset → Above 4G Decoding → Disabled

    は 無効に なっていました。

    ありがとうございます。

  • #5619 返信

    kj107

    お世話になりっぱなしで恐縮です

    bootmacos さま

    BIOSの設定を見直したら SATA の モードが AHCI に 成っていませんでした
    RST Intel の ラピット・ストレージとか言う M.2 SSD を HDD の キャッシュ として 使うやつです

    でも この設定を解除するのが 難儀 Windowsアプリで キャッシュを 無効 再起動 これで 大丈夫 と 思って
    BIOS の 設定を AHCI に 戻したら あーーーーやってしまった 何時もの如く Windows が 壊れ
    Windows の インストールから やり直しです。(BIOS 上で 元の RST の 設定に戻しても Windows が 壊れる仕様)
    (人生の多くの時間をWindowsの再インストールに割いて毎度のこと よくアメリカ人が Windowsの修復機能が 機能しない
    と Microsoft に 訴訟を起こさないのか? と 何時も思います。)

    ということで Hacintosh 作業には 時間が 掛かりそうです。

  • #5717 返信

    kj107

    お世話になります

    bootmacos さま

    マザーボード GIGABYTE H370 HD3
    CPU Core i7 8700
    ビデオカード SAPPHIRE Pulse Radeon RX Vega56 8GB HMB2
    メモリ CORSAIR DDR4-2666MHz VENGEANCE LPX Series 8GB×4枚 CMK16GX4M2A2666C16
    2.5インチ SSD 500GB / WD Blue 3D WDS500G2B0A
    OS macOS Mojave 10.14.0

    の組み合わせで ようやく Mojave インストール 成功しました。

    kextは

    AppleALC.kext
    FakePCIID_Broadcom_WiFi.kext
    FakePCIID.kext
    FakeSMC.kext
    GenericUSBXHCI.kext
    IntelMausiEthernet.kext
    Lilu.kext
    USBInjectAll.kext
    VirtualSMC.kext
    VoodooHDA.kext
    WhateverGreen.kext

    drivers64UEFIには

    ApfsDriverLoader-64.efi
    AppleImageCodec-64.efi
    AppleKeyAggregator-64.efi
    AppleUITheme-64.efi
    DataHubDxe-64.efi
    EmuVariableUefi-64.efi
    FirmwareVolume-64.efi
    FSInject-64.efi
    HFSPlus.efi
    OsxAptioFix2Drv-free2000.efi
    OsxFatBinaryDrv-64.efi
    PartitionDxe-64.efi
    SMCHelper-64.efi

    を 入れました。

    config.plistは

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <!DOCTYPE plist PUBLIC “-//Apple//DTD PLIST 1.0//EN” “http://www.apple.com/DTDs/PropertyList-1.0.dtd”>
    <!– tonymacx86 UniBeast UEFI Mode – 2018-10-01 –>
    <plist version=”1.0″>
    <dict>
    <key>ACPI</key>
    <dict>
    <key>AutoMerge</key>
    <true/>
    <key>DSDT</key>
    <dict>
    <key>#DropOEM_DSM</key>
    <dict>
    <key>ATI</key>
    <true/>
    <key>Firewire</key>
    <true/>
    <key>HDA</key>
    <true/>
    <key>HDMI</key>
    <true/>
    <key>IDE</key>
    <true/>
    <key>IntelGFX</key>
    <true/>
    <key>LAN</key>
    <true/>
    <key>LPC</key>
    <false/>
    <key>NVidia</key>
    <true/>
    <key>SATA</key>
    <true/>
    <key>SmBUS</key>
    <false/>
    <key>USB</key>
    <true/>
    <key>WIFI</key>
    <true/>
    </dict>
    <key>Debug</key>
    <false/>
    <key>Fixes</key>
    <dict>
    <key>AddDTGP</key>
    <false/>
    <key>AddHDMI</key>
    <false/>
    <key>AddIMEI</key>
    <false/>
    <key>AddMCHC</key>
    <false/>
    <key>AddPNLF</key>
    <false/>
    <key>DeleteUnused</key>
    <false/>
    <key>FakeLPC</key>
    <false/>
    <key>FixACST</key>
    <false/>
    <key>FixADP1</key>
    <false/>
    <key>FixAirport</key>
    <false/>
    <key>FixDarwin</key>
    <false/>
    <key>FixDarwin7</key>
    <false/>
    <key>FixDisplay</key>
    <false/>
    <key>FixFirewire</key>
    <false/>
    <key>FixHDA</key>
    <false/>
    <key>FixHPET</key>
    <false/>
    <key>FixHeaders</key>
    <false/>
    <key>FixIDE</key>
    <false/>
    <key>FixIPIC</key>
    <false/>
    <key>FixIntelGfx</key>
    <false/>
    <key>FixLAN</key>
    <false/>
    <key>FixMutex</key>
    <false/>
    <key>FixRTC</key>
    <false/>
    <key>FixRegions</key>
    <false/>
    <key>FixS3D</key>
    <false/>
    <key>FixSATA</key>
    <false/>
    <key>FixSBUS</key>
    <false/>
    <key>FixShutdown</key>
    <false/>
    <key>FixTMR</key>
    <false/>
    <key>FixUSB</key>
    <false/>
    <key>FixWAK</key>
    <false/>
    </dict>
    <key>Name</key>
    <string>DSDT.aml</string>
    <key>ReuseFFFF</key>
    <false/>
    </dict>
    <key>DropTables</key>
    <array>
    <dict>
    <key>Signature</key>
    <string>MATS</string>
    </dict>
    </array>
    <key>HaltEnabler</key>
    <false/>
    <key>SSDT</key>
    <dict>
    <key>DropOem</key>
    <false/>
    <key>Generate</key>
    <dict>
    <key>CStates</key>
    <false/>
    <key>PStates</key>
    <false/>
    </dict>
    </dict>
    </dict>
    <key>Boot</key>
    <dict>
    <key>Arguments</key>
    <string>dart=0 nv_disable=1</string>
    <key>Debug</key>
    <true/>
    <key>DefaultVolume</key>
    <string>MacHDD</string>
    <key>Legacy</key>
    <string>PBR</string>
    <key>Secure</key>
    <false/>
    <key>Timeout</key>
    <integer>3</integer>
    <key>XMPDetection</key>
    <string>NO</string>
    </dict>
    <key>Devices</key>
    <dict>
    <key>Audio</key>
    <dict>
    <key>Inject</key>
    <string>1</string>
    </dict>
    <key>FakeID</key>
    <dict>
    <key>ATI</key>
    <string>0x0</string>
    <key>IMEI</key>
    <string>0x0</string>
    <key>IntelGFX</key>
    <string>0x12345678</string>
    <key>LAN</key>
    <string>0x0</string>
    <key>NVidia</key>
    <string>0x0</string>
    <key>SATA</key>
    <string>0x0</string>
    <key>WIFI</key>
    <string>0x0</string>
    <key>XHCI</key>
    <string>0x0</string>
    </dict>
    <key>USB</key>
    <dict>
    <key>FixOwnership</key>
    <false/>
    <key>Inject</key>
    <false/>
    </dict>
    <key>UseIntelHDMI</key>
    <false/>
    </dict>
    <key>DisableDrivers</key>
    <array>
    <string>Nothing</string>
    </array>
    <key>GUI</key>
    <dict>
    <key>Hide</key>
    <array>
    <string>Windows</string>
    <string>BOOTX64.EFI</string>
    </array>
    <key>Language</key>
    <string>en:0</string>
    <key>Mouse</key>
    <dict>
    <key>Enabled</key>
    <true/>
    <key>Speed</key>
    <integer>8</integer>
    </dict>
    <key>Scan</key>
    <dict>
    <key>Entries</key>
    <true/>
    <key>Legacy</key>
    <string>First</string>
    <key>Tool</key>
    <true/>
    </dict>
    <key>ScreenResolution</key>
    <string>1920×1080</string>
    <key>Theme</key>
    <string>tonymacx86</string>
    </dict>
    <key>Graphics</key>
    <dict>
    <key>Inject</key>
    <dict>
    <key>ATI</key>
    <false/>
    <key>Intel</key>
    <true/>
    <key>NVidia</key>
    <false/>
    </dict>
    </dict>
    <key>KernelAndKextPatches</key>
    <dict>
    <key>#FakeCPUID</key>
    <string>0x010676</string>
    <key>AppleIntelCPUPM</key>
    <true/>
    <key>AppleRTC</key>
    <true/>
    <key>KernelCpu</key>
    <false/>
    <key>KernelLapic</key>
    <false/>
    <key>KernelPm</key>
    <true/>
    <key>KextsToPatch</key>
    <array>
    <dict>
    <key>Comment</key>
    <string>External icons patch</string>
    <key>Find</key>
    <data>
    RXh0ZXJuYWw=
    </data>
    <key>Name</key>
    <string>AppleAHCIPort</string>
    <key>Replace</key>
    <data>
    SW50ZXJuYWw=
    </data>
    </dict>
    <dict>
    <key>Comment</key>
    <string>Remove USB port limit in XHCI kext</string>
    <key>Find</key>
    <data>
    g/sPD4MDBQAA
    </data>
    <key>MatchOS</key>
    <string>10.14.x</string>
    <key>Name</key>
    <string>com.apple.driver.usb.AppleUSBXHCI</string>
    <key>Replace</key>
    <data>
    g/sPkJCQkJCQ
    </data>
    </dict>
    </array>
    </dict>
    <key>RtVariables</key>
    <dict>
    <key>BooterConfig</key>
    <string>0x28</string>
    <key>CsrActiveConfig</key>
    <string>0x3</string>
    </dict>
    <key>SMBIOS</key>
    <dict>
    <key>ProductName</key>
    <string>iMac14,2</string>
    <key>Trust</key>
    <false/>
    </dict>
    <key>SystemParameters</key>
    <dict>
    <key>InjectKexts</key>
    <string>Detect</string>
    <key>InjectSystemID</key>
    <true/>
    <key>NvidiaWeb</key>
    <false/>
    </dict>
    </dict>
    </plist>

    ※ インストールしたばかりで なんとも言えませんが、ビデオカードの RX Vega56 のファンが急に最高回転で回ってしまいます
    再起動すれば直りますが 頻度は高いです。

    それと 画面解像度が ちゃんと RX Vega56 のスペック通り 表示されているのか? 判りません。

    macOS で 再起動 を 行っても 再起動してくれず 起動HDDを読みに行かず フリーズしている感じです
    macOS で システム終了 を しても 再起動 してしまうようです。

    ここら辺の トラブルが 解決できれば と 思います。

    ご指導頂ければ 助かります

    宜しくお願いいたします。

  • #5732 返信

    kj107

    一つ 解ったこと

    前回 Core i3 8100 で 作った Hacintosh では Yahooニュースの再生が出来ませんでしたが
    今回 作った Core i7 8700 + Radeon RX Vega 56 では Yahooニュースも 問題なく再生できるように
    なりました Core i3 8100 内蔵の グラフィックス インテル® UHD グラフィックス 630 だと
    再生出来ない形式の動画があるのかも?知れません。

  • #5745 返信

    kj107

    お世話になります

    bootmacos さま

    Hacintosh では Mojaveのアップデートが 上手くできなかったので、HDDを本物のMacBookに取り付けて
    10.14.5 まで アップデートを行い Hacintosh に 戻した所 起動しなかったので
    HDDを マザーボードの SATAポートに接続して 何回か やっているうちに 起動出来るようになったのですが
    システムレポートでUSBの項目を見たところ USB3.1バス しか 認識していない事が解りました。
    (Hacintosh では HDD を 外付け USB3.1 Gen2 で 繋いでおります。SATAで繋ぎなおした時も一発では起動出来ず
    PCのリセットスイッチを押して再起動させたら macOS を 起動出来るようになったのですが 1回でもmacOSが 上手く起動できれば その後も USB3.1 Gen2 で 繋いでも 起動出来るようになるのですが 起動出来たり 出来なかったり安定しません)

    >キーマスター
    >config.plistのBoot, Argumentsに” -v”を追加します。例えば以下のように。
    >
    ><key>Boot</key>
    > <dict>
    > <key>Arguments</key>
    > <string>uia_exclude=HS01;HS03;HS04 -v</string>

    も 試してみたのですが 始動直後 進入禁止マークが出て ストップして しまいます。

    USB15制限 という意味で USBInjectAll.kext は 入れてあるのですが 上手く働いていないようです。
    (そもそも マザーボードには 15個も USB ポートが 無いのですが)

    15個制限を回避するUSBInjectAll.kextの役割と使用法

    (IORegistryExplorer という ソフトで USB の状態を 見ることは 理解出来ましたが その後の 操作が解りません)

    の USB ポートの 制御 config.plist の 書き方が 解らなくて 困っております。

    それと これは 10.14.5 に アップデート する前からなのですが、メニューバーから システム終了を 選択しても
    再起動を 選んでも 両方とも再起動が掛かってしまいます。

    再起動後 Windows を 起動して Windowsから 電源OFF を 選択すれば パソコンの電源を切ることができます。

    フォロー頂ければ 幸いです。
    宜しくお願いいたします。

    • #5751 返信

      bootmacos
      キーマスター

      シャットダウンしても起動してしまう問題は、config.plistの

      
      <key>FixShutdown</key>
      <false/>

      のところを

      <key>FixShutdown</key>
      <true/>

      にするとうまくいくかもしれません。

    • #5752 返信

      bootmacos
      キーマスター

      -vはCloverの起動画面からも設定できます。ドライブが並んでいる下のアイコンからオプションを選びます。

  • #5746 返信

    yoshii

    kj107様
    Config.plistをざっと見ましたが、機種設定から始めた方が良いかと思います。構成を見る限りではiMac 18.2がおすすめです。機種設定のやり方はこちらを参照されると良いかと思います。
    Clover Configulatorはいろいろ設定ができますので、Config.plistのエディタ編集に慣れていない段階ではおすすめです。

  • #5754 返信

    kj107

    お世話になります

    yoshii さま

    情報ありがとうございます。

    上手くFFIを作れたのは Clover_v2.4k_r4898 で 作成した macOS Mojave 10.14 でした
    これだと USB の 認識トラブルもなく 起動します。

    で、先ほど 試したのは MacBook を High Sierra で 起動して macOS Mojave 10.14.5 を ダウンロードして
    上手く行った時と 同じ UEFI ドライバ と kext を 入れで 上手く 行くかと思いましたが ダメでした。

    Clover_v2.4k_r4898 で作成したものはすぐに 侵入禁止マークが表示され 起動できませんでした。

    CLOVERX64.efi と config.plist を Unibeast9.2.0 で 作成したものに 入れ替えてみましたが
    起動は出来たものの USB3.1 しか 認識 して くれませんでした。

    yoshii さま に 教えて頂いたやり方を 試してみたいと思います。

    ありがとうございます。

  • #5758 返信

    yoshii

    Config.plistのBootに -no_compat_check を入れると機種チェックをスルーできます。
    あと -v オプションを入れると起動時に何を読み込んでいるのかを表示してくれますのでどこでエラーになっているのかがわかりやすくなります。とりあえずこの2つを追記されると良いかと思います。

  • #5759 返信

    kj107

    お世話になります

    bootmacos さま

    】シャットダウンしても起動してしまう問題は、config.plistの

    】<key>FixShutdown</key>
    】<false/>
    】のところを
    】<key>FixShutdown</key>
    】<true/>

    を教えて頂き ありがとうございます。(まだ 試せてないんですけど)

    今まで 1台の HDD で Hacintosh を していたので せっかく 10.14→10.14.5 へ Upデートしたら
    アプリも入れたのに また最初からかぁ〜 と ちょっと 疲れ気味 で 作業が進んでいませんでした。

    んで あー 2台の HDD 使って 安定している方の 10.14 で とりあえず 使っていて

    10.14.5 で 起動するディスクと分ければ良いんだ と 今更ながら気づいて 今日はようやく macOS 起動ディスクを
    2つに 分ける事にしました。
    (両方とも 外付けなのですが 片方 10.14 はマザーの SATAポートから 外部出力をして 外付けeSATAケースと繋ぎ
    10.14.5 は ラトック の USB3.1ボード 経由で USB3.1 接続で 繋ぐようにしました。
    10.14.5 は どういうわけか マザーボードの USB3.0 A ポートも USB3.0 USB C ポートも認識せず
    ラトック の USB C 3.1 ポートしか認識しません。※このボードに USB A ポートもあるのですが そちらは認識しません
    https://www.ratocsystems.com/products/subpage/usbif/peu31ac_siyou.html)

    それと 10.14.5 では HDD の データコピー中 とか 何かの拍子で フリーズ してしまい 安定しません。

    • #5760 返信

      bootmacos
      キーマスター

      まずはその10.14.5が正しく機能するかどうかを実際のMacBook Proで起動させて確認してはどうでしょうか。全く問題なく動けば、あとはEPSの問題です。

      もしそうならば、Cloverを最新にして、kext類を最新にしてみてください。Kext Updater.appがその目的に使えると思います。

      それでも動かなければ、config.plistの記述か、efiファイルの選択か、kextの選択が悪いと思います。その場合はconfig.plistとefi, kextファイルの一覧をまた公開していただければ原因を考えられると思います。

  • #5761 返信

    kj107

    お世話になります。

    bootmacos さま

    色々ご指導頂きまして 恐縮です。

    さっそくで恐縮ですが 教えて頂きました

    】シャットダウンしても起動してしまう問題は、config.plistの

    】<key>FixShutdown</key>
    】<false/>
    】のところを
    】<key>FixShutdown</key>
    】<true/>

    なのですが 現在使用中の config.plist には

    】<key>FixShutdown</key>
    】<false/>

    の記述がありませんでした。

    】<key>FixShutdown</key>
    】<true/>

    は config.plist 上の どの部分でも関係無く config.plist に 書き込めば宜しいのでしょうか?

    再度 お教え頂ける と 助かります

    宜しくお願いいたします。

    PS. ちなみに 10.14 でも システムレポートの項目でも USB3.1バスしか 認識はしていないのですが
    マザーボードのUSB2.0ポートも、USB3.0 A ポートも 追加したラトックUSB3.1ポート でも 正常に動作しているようです。

    • #5763 返信

      bootmacos
      キーマスター

      こちらの書き込みで示していただいたconfig.plistにはFixShutdownの設定が書いてあってfalseになっていたので、これをtrueにしてはどうかと思った次第です。

  • #5765 返信

    kj107

    お世話になります

    bootmacos さま

    完全に私の見落としです

    ありがとうございました。

  • #5766 返信

    kj107

    お世話になります

    bootmacos さま

    <key>FixShutdown</key>
    <false/>


    <key>FixShutdown</key>
    <true/>

    に 変更してみましたが シャットダウン出来ませんでした。

    つぎは 教えて頂いた これを 試そうと思います

    >まずはその10.14.5が正しく機能するかどうかを実際のMacBook Proで起動させて確認してはどうでしょうか。全く問題なく動け>ば、あとはEPSの問題です。

  • #5780 返信

    kj107

    お世話になります

    10.14.5 の USB 設定は 相変わらず 上手く行っていませんが、一つ 動きが安定しないものがあります
    これは 10.14 でも 同様なのですが 無線アダプターつきのマウスの動きが ギクシャク します
    ポインタが スムースに追従しなくて飛ぶような動きや Dockのアプリをクリックするときにプチフリーズするような
    動作となります。

    起動直後はそれほどでもないのですが 使い続けると もっと酷くなるような感じがします。

    これも USB 設定が 上手くできていないせいでしょうか?

    • #5831 返信

      bootmacos
      キーマスター

      Bluetoothが途切れる問題は色々な妨害電波に対してBluetoothの電波強度が弱いのが原因だと思います。対策はこちらの記事をご覧ください

      バージョンに関してはyoshiiさんのおっしゃる通り、必ず最新版を使うべきです。Cloverもefiドライバ類もkext類も全て最新版が良いです。古いバージョンでは現行macOSが動かない場合があります。H370をお使いのようですので、安心して最新版を使うのが良いです。

    • #5832 返信

      bootmacos
      キーマスター

      補足です。もしかしてBluetoothではなかったのでしょうか?

      専用の無線規格を用いた無線マウスであってもBluetoothと同じ2.4GHz帯の電波を使っていますので、同様に他の妨害電波の影響を受けます。USBドングルを使っている場合は、アンテナを増設できませんので、その場合は、USB延長ケーブルを用意して、机の上にUSBドングルを置けるようにして、マウスに近づけてみてはどうでしょうか。

  • #5793 返信

    kj107

    Clover の バージョンについて教えてください。

    私は Clover_v2.4k_r4898 を 使用して Hacintosh を していますが
    Clover の 新しいバージョンを 使用して EFIドライバ、kext を 入れても
    Hacintosh は 上手く行きません。

    Clover の 新・旧 の バージョンの 違いでは どうゆう影響があるのでしょうか?

    投稿記事で見ましたが、確かに 新しい チップセットのマザーボード や CPU や グラフィックボードが
    出た時に それに対応する為 Clover の 新しいバージョンが必要になってくることは解りますが

    新しいバージョンの Clover では 1世代前 とか 古いハードは サポートされない 仕様で作られているものなのでしょうか?
    (自分のマザーボードやCPUが古くなった時 新しいバージョンの macOS を インストールしようとした時
    自分のハードに合った世代のCloverを使用すべきなのか? それとも 新しいClover を 使用した方が 新しい macOS に
    対しての成功率が高くなるのか? を 知りたいです。 )

    教えて頂けると有り難いです。

    宜しくお願いいたします。

  • #5816 返信

    yoshii

    Cloverは基本最新版を使うべきだと思います。古いマシン、例えばSandy Bridge+Z68チップセットといった組み合わせでも最新のCloverで動きます。
    r4988からフォルダ構成やドライバ類が変わったのでCloverのインストールを完全にやり直してみるのも良いのではないかと思います。

  • #5865 返信

    kj107

    お世話になります

    bootmacos さま

    情報ありがとうございます。

    >Bluetoothが途切れる問題は色々な妨害電波に対してBluetoothの電波強度が弱いのが原因だと思います。
    >対策はこちらの記事をご覧ください。

    マウスは Bluetooth接続ではなく USB子機を使った 2.4Ghz帯 無線マウス を 接続しています。
    (Bluetooth マウスは 試していませんが Bluetoothマウスの方が Hcintosh では 相性が良いのでしょうか?)

    宜しくお願いいたします。

    • #5868 返信

      bootmacos
      キーマスター

      USBドングルを使った無線マウスでしたら、先に書きましたように、USB延長ケーブルを使って、マウスの近くにUSBドングルを持ってくれば電波がかなり改善されると思います。私も同じような経験があります。

      Bluetoothマウスの方が相性が良いということは無いです。専用2.4GHzでもBluetoothでもマウスの安定性は同じだと思います。Windowsでも同じだと思います。

      ただ、現在のmacOSの使い勝手はトラックパッドのマルチタッチジェスチャにかなり依存しています。トラックパッドならマルチタッチスクロールとか、スワイプとか、ピンチなどが使えるのですごく便利です。マウスを使っていたらmacOSの素晴らしさの70%くらいしか体験できていないと思います。macOSの一部だと思います。高価ですがぜひともMagic Trackpad 2を使ってみてください。最初は指がつる感じがしますが、すぐに慣れます。慣れたらもうマウスには戻れません。無料でmacOSを使わせていただいている代金を、トラックパッド代でアップル社にお支払いすると思えば良いのです🙂。その場合、Bluetooth接続になります。

      Magic Trackpad 2は良いです

      • この返信は2 ヶ月、 1 週前に  bootmacos さんが編集しました。
  • #6085 返信

    kanagu

    >kj107さま
    マウスがフリーズを繰り返すような症状について、既に解決しているかもしれませんが。。

    自分もロジクールのBluetoothマウス(MX Master 2S)を使っていると同じ症状でした。(USBレシーバーで使っていた時も症状は出ていました)
    でもAppleのMagicMouseだと平気です。

    で下記2点で現在は解決してます。(多分1番目の方で直ぐに解決したような気がしてます。2番目はおまじないで。)
    [1]「システム環境設定」→「ネットワーク」の「Bluetooth PAN」を削除(次回以降も表示しないように設定)
    [2]メニューバーにBluetoothが表示されるようにした状態で「shiftキー」と「optionキー」を同時押しでBluetoothのアイコンをクリック。メニューに出てくる「デバッグ」から「Bluetoothモジュールのリセット」を行う。

    で再起動してからは自分は症状が全く出なくなりました。
    Bluetoothでネットに繋いでいる場合はちょっと困るかもしれませんが、WiFiなりLANなりで接続しているのであれば一度試してみて下さい。

  • #6226 返信

    kj107

    お世話になります

    kanagu さま

    返信遅くなって恐縮です。
    マウスの問題解決の詳細ありがとうございます。

    家の環境ですと どうも Bluetooth の 電波が干渉するようで (要は壁が薄い)
    Bluetooth接続のオーディオも 途中で通信が切断されることも多く発生しています。
    Bluetoothオーディオ の 件は Apple サポートにも 相談してみたのですが 解決せず
    パソコンを隣の部屋と一番遠い部屋(外に近い部屋) に 持って行くと Bluetoothが 途切れない事が解りました。

    >AppleのMagicMouse

    は 持っていないので 解りませんが Bluetooth 接続よりは
    無線USB子機 で 繋ぐ マウスの方が まだ 繋がりが良いようです。

返信先: [HELP] GIGABYTE H370 HD3+8700+Vega56」
あなたの情報: