[Success] i7 3700K, B75M-PLUS,Geforce 1050Ti(High Sierra,WIndows,Ubuntu)

ホーム フォーラム User Builds [Success] i7 3700K, B75M-PLUS,Geforce 1050Ti(High Sierra,WIndows,Ubuntu)

  • このトピックには20件の返信、2人の参加者があり、最後にmifjpnにより2ヶ月、 3週前に更新されました。
18件の返信スレッドを表示中
  • 投稿者
    投稿
    • #6336 返信
      mifjpn
      ゲスト

       古くなった、サブ機にHDDをたして、Geforceの動くHigh Sierraをいれて、トリプルブートにしてみました。

       チップセットが古いので、いろいろな問題が出るかと思いきや、Coffee lake用のconfig.plist(Cloverも最新)が意外にうまく動いちゃいました。
       USBインストーラーのEFI
      USB.i3770K.B75.EFI.zip
      HDDのEFI
      HDD.i3700K.B75.nVidia.EFI.zip
      共有領域として、exFATで500GBほどパーティションを切り、UBUNTUでもマウントできました。
       面白い動きだったのが、USBのIORegistryExplorerでの結果でした。
       全部認識するパッチを入れましたが、XHCには8つ(HS01〜HS04,SS01〜SS04)しか見えていません。
       USB3.0は4つなのですべて見えていますが、USB2.0のキーボードやマウスが見えません。
       EHC1,EHC2にバックポート全部(4つ)のUSB2.0が繋がっており、こちらにキーボードとマウスが見えました。
       通常、EHC1→EH1,EHC2→EH2などして、衝突を防ぐのかなとおもって、パッチでリネームしても、結果はEH1,EH2に名前が変わっただけで同じでした。
       

    • #6337 返信
      mifjpn
      ゲスト

      すいません。イメージを2つ入れときます。

    • #6345 返信
      mifjpn
      ゲスト

      すみません。EFIのURLがおかしいですね。
      USB.i3770K.B75.EFI.zip

      HDD.i3700K.B75.nVidia.EFI.zip

      失礼しました。

    • #6348 返信
      bootmacos
      キーマスター

      B75チップセットは4個のUSB 3.0と8個のUSB 2,0があって、どちらもチップセットでサポートされているけど、別のインタフェースで実装されているようですね。そのおかげで、インタフェースあたり15個の制限には関係なく、何もしなくても全部認識されるってことなのかなと思います。

      https://www.asus.com/jp/Motherboards/B75MPLUS/specifications/

      • この返信は5ヶ月、 4週前にbootmacosが編集しました。
    • #6352 返信
      mifjpn
      ゲスト

      応答ありがとうございます。
      ちょっと調べてみました。
      マザーボードの裏側のUSBポートです。

      USB2.0のみのポートはEHC1,EHC2(その先にAppleUSB20Hubportで8本になっているようです。)
      USB3.0,2.0共用のポートはいつものXHC@14のHS,SSが対応していました。
      実装の仕方がちがうんですねぇ。

    • #6363 返信
      mifjpn
      ゲスト

      補足:たまに起動に失敗するので、調べてみると、
      0x1000000-10FFFFFにカーネル配置できない部分がありました。
      0x100000からわずか16MB程度です。
      0x100000+ x * 0x200000=0x1100000
      x * 0x200000 = 0x1100000-0x100000=0x1000000
      x = 0x1000000 / 0x200000=0x08
       ランダムシード値が0~7のときに起きるんですから、本当にまれなのですが、やっぱりそういうときもあるんですね。
       slide=8
       CsrActiveConfigを0x40で調整しました。(上のHDDのEFIは調整済みです)

      • #6366 返信
        bootmacos
        キーマスター

        参考になる情報ありがとうございます。たまに起動しないというマザーボードに遭遇することがありますが、こういう状況のこともあるんですね。

    • #7108 返信
      yaaboo
      ゲスト

      私も同じCPUとマザーボードを使用して作成してみたいと思っています。もしよろしければ、作成方法の詳細について教えていただけないでしょうか?無知でもうしわけございませんが、私がやってみたこと。
      HACKINTOSHの作り方(総集編:10.13版) のページを参考にUSBメモリを作成 ➡︎ boot 0 error で起動できず。
      TONYMACX86式インストール手順 を参考に Legacy Boot Mode(こっちでいいのでしょうか?) でmacOSをインストール SSDにインストールできた。 今ここです。(MULTIBEASTはこれから)
      なんか間違っている気がして質問させていただきました。よろしくお願いします。

      • #7109 返信
        mifjpn
        ゲスト

        お疲れさまです。
         全く同じ環境であれば、
        USBメモリを消去のあと、名前をUSBとして、(High Sierraのインストーラーのある環境から)

        
        sudo /Applications/Install¥macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB
        
        

        (そういえば、元には\がかいてありませんね。^^;)
        で、インストーラーを入れてから、
         一番かんたんなのは、上のUSB.i3770K.B75.EFI.zipを展開し、Clover ConfigratorでUSBメモリのEFIパーティションに入れれば(左のMount EFIを選択、右下にUSBメモリの名前が出てくるので、Mount、Open Partitionで、EFIパーティションが開きます)インストールUSBメモリスティックができ、起動できるるはずです(F8でBootOptionが出ます。)。(すいません、反対にLegacy Boot Modeを使ったことがないのでわかりません。^^;)

         後に、NvidiaのGPUボードを入れれば、HDD.i3700K.B75.nVidia.EFI.zipを(インストール先の)EFI領域に入れればいいと思います。

         最後にKext Updaterでアップデートをダウンロードして、Cloverの再インストール(UEFI,ESPの方で入れます。各種efiファイル(ドライバ)のインストールチェックを、今入っているefiファイル(EFI/CLOVER/drivers/UEFI以下にあります。)と同じであるのを確かめたほうがいいと思います。)、Kextの上書きアップデートをすればいいと思います。
         すみません、取り急ぎ書きましたので・・・不明なところがあったら、お知らせください。

         頑張ってください。
         
        なお、古い内蔵グラフィックはほとんど使ったことがないので、よくわかりません。悪しからず、ご了承ください。

    • #7110 返信
      mifjpn
      ゲスト
      
      sudo /Applications/Install/macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB
      

      ですね。失礼しました

    • #7118 返信
      mifjpn
      ゲスト

      それぞれ新しいのをおいておきます。
      SMBIOS(機体固有の番号関係)はランダムに振り直してあるので、そのままお使いください。
      USBメモリのEFI
      USB.EFI.3770.B75.5098.zip
      HDDのEFI
      HDD.EFI.3770.B75.Nvidia.5098.zip

      うまくいくこと願ってます。

    • #7125 返信
      yaaboo
      ゲスト

      mifjpnさま

      ご親切にどうもありがとうございます。

      お陰様でOSはインストールできました。

      >HDD.i3700K.B75.nVidia.EFI.zipを(インストール先の)EFI領域に入れればいいと思います。

      Clover Configurator をつかってコピペしました。SMBIOS(機体固有の番号関係)まで変更していただきありがとうございます。

      >最後にKext Updaterでアップデートをダウンロードして、Cloverの再インストール(UEFI,ESPの方で入れます。各種efiファイル(ドライバ)のインストールチェックを、今入っているefiファイル(EFI/CLOVER/drivers/UEFI以下にあります。)と同じであるのを確かめたほうがいいと思います。)、Kextの上書きアップデートをすればいいと思います。
       
      これは、Kext UpdaterのCHECKボタンを押すだけでいいのでしょうか?
      また、ビデオカードは980tiをさしてあるのですが、認識されていません。ドライバーをKext Updaterからダウンロードしてもインストールすることができません。(アップデートが必要等なことをいわれます)
      Kext Updater によると システムバージョンはは  10.13.6 17G66 でした。

      お言葉に甘えてしまって申し訳ございませんが、ご教授願えると助かります。

    • #7126 返信
      mifjpn
      ゲスト

       うまく行ったんですね、おめでとうございます。もう少しですね。
      USB関係の心配のないチップセットなので、使いやすいですよね。

      ◎まず、Kext Updaterでのアップデートは、checkを押せば、バージョンアップが足りないところについては自動でダウンロードしてくれます。ただ、Clover Bootloaderだけは、

      https://github.com/CloverHackyColor/CloverBootloader/releases

      から、リリースをチェックし、pkgをダウンロードする必要があります。
       現状でここに上げたEFIはそのままアップデート済みの判断になると思います。

      ◎あとNvidia Web Driverですが、まとまってるのは、今はココだと思います。

      https://www.tonymacx86.com/nvidia-drivers/

       OS Buildにあったものをダウンロードし、pkgでインストールとなります。メニューバーにNVIDIA Driver Managerが出ますので、そこで、NVIDIA driverを選択すればいいと思います。(再起動もいるかも知れません。)
       一度インストールすると、OSのアップデートごとに通常自動でアップデートされるので、pkgでのインストールは1度だけで、あとは、アップデート後の処理にしたがって行けばいいと思います。(というわけなので半分忘れてます^^;)
       HDD.i3700K.B75.nVidia.EFI.zipの方は、実際に現在のNVIDIA Web Driverで動いてるものなので、設定の方は問題ないと思います。
       余談ですが、システムのビルド番号は、メニューバーの左のアップルマーク→このMacについて→「バージョン 10.13.6」の数字部分あたりをクリックすると出ます。

      うまくいくことを祈っています。

    • #7127 返信
      mifjpn
      ゲスト

      すみません。
      17G66は問題になっていたみたいですね。
      https://www.tonymacx86.com/threads/nvidia-driver-for-17g66.269272/
      のとおり、
      bash <(curl -s https://vulgo.github.io/webdriver) 387.10.10.10.40.113
      が正しいんでしょうか?
      自分がインストールしたときは、どうしてたんでしょう?
      High Sierraのインストーラーのバージョンが違ったのかもしれません。

    • #7128 返信
      mifjpn
      ゲスト

      お疲れさまです。
       17G66にダウングレードインストールして試して見ました。(ちょうどインストーラーの期限切れだったので気がついてよかったです。)
      17G66用のNVIDIA DRIVERはありませんが、
       そのまましばらく待つと、下のドックのアプリにアップデートの印が出ます。
      それがSafariとセキュリティアップデート2019−006です。
      これに従いアップデートするとビルドが17G9016になります。
       そこで、TonymacのNVIDIA DRIVER 387.10.10.10.40.132をインストールすればいいとおもいます。
      成功を祈ります。

    • #7129 返信
      yaaboo
      ゲスト

      mifjpnさま

      情報ありがとうございます。

      >bash <(curl -s https://vulgo.github.io/webdriver) 387.10.10.10.40.113

      なにかがインストールされたみたいなのですが、グラボは認識しませんでした。

      systemversion.plist を直接いじって偽装する方法があるようですが、パミッションエラーで変更できず。

      リカバリー・モードで起動し[ユーティリティ]-[ターミナル]から $ csrutil disable コマンドで SIP(システム統合性保護)を無効にして再起動したところ、編集できるようになりました。

      との記事があったのですが、CLOVERでリカバリー・モードで起動できるのでしょうか?

      また、インストーラーのバージョンはダウンロード毎に変わるものなのでしょうか?

    • #7130 返信
      mifjpn
      ゲスト

      お疲れさまです。
       すいません。
       インストーラーは、AppStoreを使ったり、Patcherをつかったりと、ダウンロード方法に別があるので、もしかしたらと思いましたが、ビルドにかわりはないだろうと思います(きっとAppleの同じところから読んでるのでしょう。)。

      ◎過去の事跡(メモ)をみたところ、やはり、アップデートを先にかけてから、NVIDIA Web Driverのpkgをあてていました。それにしても、ダウンロードできる17G66だけDriverがないというのは、ちょっと悲しいですねぇ^^;

       RecoveryやPrebootモードは、cloverのconfig.plistで、ブートメニューボタンから省くように設定されているはずです。Clover ConfigratorでBoot関係の項目(GUIだったかしら?)見てみると出てくると思います。また、起動の時のCloverのメニューボタンの表示時にF3ボタンを押すと全部のボタン(メニューエントリ)が見えると思います。

       回り道させてしまったようですみませんでした。
       うまくいくこと祈念します。:)

    • #7131 返信
      yaaboo
      ゲスト

      mifjpnさま

      ダウングレードまでしていただき本当に感謝の念しかございません。

      おっしゃる通りアップデートをかけたら17G9016となりあっさりとWeb Driverがインストールできました。

      完成した達成感と試行錯誤していた時のワクワク感が無くなってしまう寂しさがあり複雑です。(笑)

      あとPCIにSound Blaster X-Fi SB0460を差しているのですが、サウンドカードから音声を出力する方法をもしご存じでしたらご教授願えればと思っております。不躾なお願いで申し訳ございません。(内臓スピーカーとHIMD出力はできました。感謝です)

    • #7132 返信
      mifjpn
      ゲスト

      お疲れ様です。
      Sound Blaster X-Fi SB0460については、google先生に聞くぐらいしかできませんねぇ^^;
      X-FiのPCI-Eだと、VooDooで行けるようなことは書いてありますが、
      PCI版は検索に引っかかりませんねぇ。

      健闘を祈ります。

    • #7156 返信
      yaaboo
      ゲスト

      mifjpnさま

      いろいろとありがとうございました。

      mifjpnさんは一番下のPCIってなにか活用されているのでしょうか?

    • #7198 返信
      mifjpn
      ゲスト

      お疲れ様です。
       PCIのボードはさすがになくなりましたねぇ・・・IRQ問題で、差し込む位置にまで、気を配ったものですが懐かしい思い出です。
       簡易式のファイルサーバ(USBのHDDアレイ)を、作って使ってますが、以前にはUSB2.0増設用にPCIのボードを使ったのが最後でした。
       今は、PCI-Ex(x1)でUSB3.0運用です。USBも3.0になってからは、UBUNTUのSAMBAサーバも早くなり、かなり便利になりました。
       そういえば、反対に、PCI-Ex(x1)のために、薄型のVGAカード(隣のx16に刺すので)を探しましたねぇ^^;ww
      UBUNTUは便利なのですが、IGPUでは、VNCの仮想デスクトップ環境がうまく動かなかったんですよ。いつもは、UBUNTUマシンには「お下がりの部品」で問題なかったんですが、VGAはあれから、高価格化、高スペック化して、ミドル~ロースペックでも分厚いのが手に入りやすくなりましたから。NVIDIA GeForce 210になりました。なんかこうおまじない程度スペックですが、役立つときもあるんですねぇ^^;ww
       ちょっとお話が長くて失礼しました。

18件の返信スレッドを表示中
返信先: [Success] i7 3700K, B75M-PLUS,Geforce 1050Ti(High Sierra,WIndows,Ubuntu)
あなたの情報: