macOSをアップデートしたらNUCが起動しない

Intel NUCのmacOSをアップデートしようとしたら起動しなくなりました。原因は、CMOSメモリーバックアップ関係のようです。電池交換しても改善しませんでしたので、電池なしで使うことにしました。Hackintos自体の問題ではないのですが、ありがちなトラブルの一つなのかと思います。

OSアップデートで不調に

IntelのNUCは、小型省電力のHackintoshを作るのに適しているので

Haswell搭載のD54250WYKHでmacOSをサーバにしています。これをmacOS 10.14.2で動かしていたものを、10.14.3にアップグレードしようとしたことがトラブルの発端でした。Mojaveになってから一部のHackintoshで、macOSインストーラが止まってしまうトラブルがあります。

このNUCもその一つで、High SierraからMojaveへのアップデート、10.14 –> 10.14.1, 10.14.1–>10.14.2のアップデートでこの問題が発生しました。mSATA経由のSSD(システムとユーザデータ用)とSATA経由の2.5インチHDD(データ保存用)を搭載しているのですが、HDDを一時的に外すことで問題なくアップデートできました。今回試みた10.14.2–>10.14.3へのアップデートでも同様に、「インストーラリソースが見つかりません。」のメッセージが出ました。そこでHDDを取り外すことにしました。

HDD取り外しのために、電源を外して、裏蓋を開けて、HDDを取り外します。その後、起動しようとしたのですが、画面に何も表示されなくなりました。電源LEDも点灯しません。何度か試しているうちに、CPUファンが高回転で回り始めました。でも画面には相変わらず何も表示されません。

EFIのCMOSが原因?

UEFIの設定画面を含めて画面への表示が一切出ません。NUCのファームウェア関係の問題のようです。念のために、HDD、SSD、無線LANカードなど、メモリー以外の後付け部品を取り外しました。が、症状は変わりません。

検索したらこんな情報がありました。

この人は、Ubuntuを入れていたようです。CMOSメモリのバックアップ用ボタン電池を外して戻したら復活したとあります。この方法を試してみることにしました。ボタン電池は、基板の裏側にあるので、相当分解しないと到達しません。基板はギリギリでハマっているので、外すには手間がかかります。ようやくボタン電池に行き着いて、取り外したところ無事起動しました。CMOSデータのチェックサムがおかしいとか、時刻が未設定とのメッセージが出ます。電池外したので当然かと思います。UEFI設定画面も出たので、念のために工場出荷時状態にリセットして、Hackintosh用の設定(iGPUへの割り当てメモリを増やす、Vt-Dをdisableにする、起動ドライブを設定する)を行いました。

これで無事、10.14.3にアップデートできました。ただ、ボタン電池をつけた状態で、電源を外すと再び起動不可能になるようです。ボタン電池を外したままなら、時刻が初期化されますが、正常に起動します。そのほかのUEFIの設定は、短時間電源を外したくらいでは消えないようでした。ボタン電池が消耗していて中途半端にバックアップされているようにも思えます。ただ、ボタン電池の電圧をテスターで測ると3.25ボルトあるので、無負荷ならば電圧に問題はないようです。

そこで同等のボタンを取り寄せて、取り付けてみました。新品の電池は3.40V程度でしたので、改善するかと思いましたが、電残念ながら結果は同じです。CMOSメモリ本体の問題なのかもしれません。ということで電池を外したまま運用することにしました。ACアダプタを抜かなければ、起動に問題はありません。ACアダプタを抜いても、CMOSの内容が一部クリアされることと、時刻がリセットされること、チェックサムエラーの警告が出るだけです。起動ドライブが変わってしまうので設定し直す必要がありますが、それ以外の手間はありません。時刻も、macOSが起動すればNTPサーバから時刻を取り寄せて設定してくれます。

返信を残す

メールアドレスが公開されることはありません。

「名前」「メールアドレス」「サイト」は空白でも投稿できますが、日本語が含まれない投稿は無視されます。(スパム対策)